|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 10 1/13 Information Library|
- modify parameters of metadevices
/usr/sbin/metaparam [-s setname] [concat/stripe or RAID5 options] concat/stripe RAID
/usr/sbin/metaparam [-s setname] [mirror options] mirror
The metaparam command is used to display or modify current parameters of metadevices.
If just the metadevice is specified as an argument to the metaparam command, the current settings are displayed.
The metaparam command enables most metadevice (volume) parameters to be changed. Only the interlace value cannot be changed by metaparam, because it is established when the metadevice is created and cannot be changed thereafter.
Root privileges are required for all of the options.
The following options are supported:
Displays usage message.
Specify the name of the diskset on which metaparam works. Using the -s option causes the command to perform its administrative function within the specified diskset. Without this option, the command performs its function on local metadevices.
Specifies the hot spare pool to be used by a metadevice. If none is specified, the metadevice is disassociated with the hot spare pool assigned to it. If the metadevice is currently using a hot spare, then metaparam cannot replace the hot spare pool.
Specifies the metadevice name of the concatenation, stripe, or concatenation of stripes, or of the RAID5 metadevice.
Modifies the read option for a mirror. The -r option must be followed by either roundrobin, geometric, or first. roundrobin, which is the default action under the metainit command, specifies reading the disks in a round-robin (load balancing) method. geometric allows for faster performance on sequential reads. first specifies reading only from the first submirror.
Modifies the write option for a mirror. The -w option must be followed by either parallel or serial. parallel, the default action under the metainit command, specifies that all writes are parallel. serial specifies that all writes are serial.
A number from 0-to-9 that specifies the order in which a mirror is resynced during reboot. The default is 1. Smaller pass numbers are resynced first. Equal pass numbers are run concurrently. If 0 is used, the mirror resync is skipped. 0 should only be used for mirrors mounted as read-only, or as swap.
Specifies the metadevice name of the mirror.
Example 1 Associating Hot Spare Pool with RAID5 Metadevice
This example associates a hot spare pool, hsp005, with a RAID5 metadevice, d80.
# metaparam -h hsp005 d80
Example 2 Changing Read Option to Geometric
This example changes the read option on a mirror d50 from the default of roundrobin to geometric.
# metaparam -r geometric d50
The following exit values are returned:
An error occurred.
See attributes(5) for descriptions of the following attributes:
mdmonitord(1M), metaclear(1M), metadb(1M), metadetach(1M), metahs(1M), metainit(1M), metaoffline(1M), metaonline(1M), metarecover(1M), metarename(1M), metareplace(1M), metaroot(1M), metaset(1M), metassist(1M), metastat(1M), metasync(1M), metattach(1M), md.tab(4), md.cf(4), mddb.cf(4), md.tab(4), attributes(5), md(7D)