|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 10 1/13 Information Library|
- STREAMS error logger daemon
strerr receives error log messages from the STREAMS-based log driver (see log(7D)) and appends them to a log file. The resultant error log files reside in the directory /var/adm/streams, and are named error.mm-dd, where mm is the month and dd is the day of the messages contained in each log file.
The format of an error log message is:
<seq> <time> <ticks> <flags> <mid> <sid> <text>
error sequence number
time of message in hh:mm:ss
time of message in machine ticks since boot priority level
T : the message was also sent to a tracing process F : indicates a fatal error N : send mail to the system administrator (hardcoded as root)
module ID number of source
sub-ID number of source
formatted text of the error message
Messages that appear in the error log are intended to report exceptional conditions that require the attention of the system administrator. Those messages which indicate the total failure of a STREAMS-based driver or module should have the F flag set. Those messages requiring the immediate attention of the administrator will have the N flag set, which causes the error logger to send the message to the system administrator using mail. The priority level usually has no meaning in the error log but will have meaning if the message is also sent to a tracer process.
Once initiated, strerr continues to execute until terminated by the user. It is commonly executed asynchronously.
error log file.
See attributes(5) for descriptions of the following attributes:
There is no restriction to the number of strerr processes opening the STREAMS–based log driver at a time.
If a module or driver is generating a large number of error messages, running the error logger will cause a degradation in STREAMS performance. If a large burst of messages are generated in a short time, the log driver may not be able to deliver some of the messages. This situation is indicated by gaps in the sequence numbering of the messages in the log files.