|Skip Navigation Links|
|Exit Print View|
|man pages section 7: Device and Network Interfaces Oracle Solaris 10 1/13 Information Library|
- Flow Accouting module
The flow accounting module flowacct enables you to record flow details. You use flow details to gather statistics and/or for billing purposes. Accounting consists of recording flow details in a location you designate and in a format that you can retrieve at a later stage. IPQoS accounting relies on the exacct mechanism to store and retrieve flow information.
A flow is defined by the 5-tuple - saddr, sport, daddr, dport and protocol.
Typically, the accounting module is the last datapath element in a sequence of actions. Flow attributes include ToS/DS, user id, project id, creation time (time the flow was created), last seen (when pkts for the flow were last seen), action name (instance that recorded the flow information), nbytes and npackets. Attributes are split into groups entitled basic and extended. The basic group records only the nbytes, npackets and action name, while the extended group is a superset of the basic group and records all attributes. The attributes to be recorded, in addition to the accounting file that contains flow details, are selected using acctadm(1M). The flowacct module does not provide a mechanism to retrieve flow information from the accounting file nor to interpret the retrieved information.
The flowacct module exports the following statistics available through kstat:
module: flowacct instance: <action id> name: Flowacct statistics class <action name> bytes_in_tbl <bytes in the flow table> epackets <packets in error> flows_in_tbl <flow records in the flow table> nbytes <number of bytes through this instance> npackets <number of packets> usedmem <memory, in bytes, used by the flow table>
See attributes(5) for descriptions of the following attributes: