|Skip Navigation Links|
|Exit Print View|
|man pages section 7: Device and Network Interfaces Oracle Solaris 10 1/13 Information Library|
- DTrace statically defined tracing provider
The sdt driver is a DTrace dynamic tracing provider that performs dynamic instrumentation at statically-defined locations in the Solaris kernel.
The sdt provider allows kernel developers to explicitly create probes at formally designated locations in the operating system kernel and loadable modules, allowing the implementor to consciously choose the points in their code that are desired probe points, and to convey some semantic knowledge about that point with the choice of probe name and a relevant set of arguments.
The sdt driver is not a public interface and you access instrumentation offered by this provider through DTrace. Refer to the Solaris Dynamic Tracing Guide for a description of the public documented interfaces available for the DTrace facility and the probes offered by the sdt provider.
See attributes(5) for a description of the following attributes:
Solaris Dynamic Tracing Guide