|Skip Navigation Links|
|Exit Print View|
|man pages section 7: Device and Network Interfaces Oracle Solaris 10 1/13 Information Library|
- the null file, also called the null device
Data written on the null special file, /dev/null, is discarded.
Reads from a null special file always return 0 bytes.
Mapping a null special file creates an address reservation of a length equal to the length of the mapping, and rounded up to the nearest page size as returned by sysconf(3C). No resources are consumed by the reservation. Mappings can be placed in the resulting address range via subsequent calls to mmap with the -MAP_FIXED option set.