Go to main content

Oracle Solaris Cluster 4.3 Reference Manual

Exit Print View

Updated: September 2015
 
 

ScalMountPoint(5)

Name

SUNW.ScalMountPoint, ScalMountPoint - resource type implementation for a scalable file-system mount point

Description

The SUNW.ScalMountPoint resource type represents a scalable file-system mount point. An instance of this resource type represents the mount point of one of the following types of file systems:

The SUNW.ScalMountPoint resource type is a scalable resource type. An instance of this resource type is online on each node in the node list of the resource group that contains the resource.

To register this resource type and create instances of this resource type, use one of the following means:

  • Oracle Solaris Cluster Manager

  • The clsetup utility, specifying the option for configuring Oracle Solaris Cluster Support for Oracle Real Application Clusters

  • The following sequence of Oracle Solaris Cluster maintenance commands:

    1. To register this resource type, use the clresourcetype command.

    2. To create instances of this resource type, use the clresource command.

Standard properties and extension properties that are defined for the SUNW.ScalMountPoint resource type are described in the subsections that follow.

Standard Properties

For a description of all standard resource properties, see the r_properties(5) man page.

Standard resource properties are overridden for this resource type as follows:

Monitor_start_timeout
Minimum

10

Default

300

Monitor_stop_timeout
Minimum

10

Default

300

Postnet_stop_timeout
Minimum

60

Default

300

Prenet_start_timeout
Minimum

60

Default

300

Start_timeout
Minimum

60

Default

300

Stop_timeout
Minimum

60

Default

300

Thorough_probe_interval
Default

300

Update_timeout
Minimum

60

Default

300

Validate_timeout
Minimum

60

Default

300

Extension Properties

The extension properties of this resource type are as follows:

Debug_level

This property specifies the level to which debug messages from the resource for a file-system mount point are logged. When the debug level is increased, more debug messages are written to the log files.

Data type

Integer

Default

0

Range

0-10

Tunable

Any time

FileSystemType

This property specifies the type of file system whose mount point the resource represents. You must specify this property. Set this property to one of the following values:

nas

Specifies that the file system is a file system on a NAS device.

s-qfs

Specifies that the file system is a Sun QFS shared file system.

Data type

String

Default

No default defined

Range

Not applicable

Tunable

When disabled

IOTimeout

This property specifies the timeout value in seconds that the fault monitor uses for file input/output (I/O) probes. To determine if the mounted file system is available, the fault monitor performs I/O operations such as opening, reading, and writing to a test file on the file system. If an I/O operation is not completed within the timeout period, the fault monitor reports an error.

Data type

Integer

Default

300

Range

5-1800

Tunable

Any time

Monitor_retry_count

This property specifies the maximum number of restarts by the process monitor facility (PMF) that are allowed for the fault monitor.

Data type

Integer

Default

4

Range

No range defined

Tunable

Any time

Monitor_retry_interval

This property specifies the period of time in minutes during which the PMF counts restarts of the fault monitor.

Data type

Integer

Default

2

Range

No range defined

Tunable

Any time

MountOptions

This property specifies a comma-separated list of mount options that are to be used when the file system that the resource represents is mounted. This property is optional. If you do not specify a value for this property, mount options are obtained from the file system's table of defaults.

  • For a Sun QFS shared file system, these options are obtained from the /etc/opt/SUNWsamfs/samfs.cmd file.

  • For a file system on a NAS device, these options are obtained from the /etc/vfstab file.

Mount options that you specify through this property override the mount options in the file system's table of defaults.

Data type

String

Default

""

Range

Not applicable

Tunable

When disabled

MountPointDir

This property specifies the mount point of the file system that the resource represents. The mount point is the full path to the directory where the file system is attached to the file system hierarchy when the file system is mounted. You must specify this property.

The directory that you specify must already exist.

Data type

String

Default

No default defined

Range

Not applicable

Tunable

When disabled

RebootOnFailure

This property specifies whether to reboot the local system when failure is detected by the probe. By default, RebootOnFailure is set to FALSE. When this property is set to FALSE, the resource is disabled when a failure is detected by the probe. When this property is set to TRUE, all devices that are used by the resource, directly or indirectly, must be monitored by disk-path monitoring.

If RebootOnFailure is set to TRUE and at least one device is found available for each entity specified in the GlobalDevicePaths, FileSystemMountPoints, or Zpools property, the local system is rebooted. The local system refers to the global-cluster node or the zone-cluster node where the resource is online.

Default

FALSE

Tunable

Anytime

TargetFileSystem

This property specifies the file system that is to be mounted at the mount point that the MountPointDir extension property specifies. You must specify this property. The type of the file system must match the type that the FileSystemType property specifies. The format of this property depends on the type of the file system as follows:

  • For a Sun QFS shared file system, set this property to the name that was assigned to the file system when the file system was created. The file system must be correctly configured. For more information, see your Sun QFS shared file system documentation.

  • For a file system on a NAS device, set this property to nas-device:path. The replaceable items in this format are as follows:

    nas-device

    Specifies the name of the NAS device that is exporting the file system. You can optionally qualify this name with a domain.

    path

    Specifies the full path to the file system that the NAS device is exporting.

    The NAS device and the file system must already be configured for use with Oracle Solaris Cluster. For more information, see Oracle Solaris Cluster With Network-Attached Storage Device Manual .

Data type

String

Default

No default defined

Range

Not applicable

Tunable

When disabled

Examples

Example 1 Creating a ScalMountPoint Resource

This example shows the creation of a ScalMountPoint resource to represent the mount point of a Sun QFS shared file system that is used with Solaris Volume Manager for Sun Cluster. The resource is named scal-db_qfs-Data-rs. The characteristics of the file system are as follows:

  • The mount point of the file system is /db_qfs/Data .

  • The file system that is to be mounted is Data.

  • Mount options are obtained from the file system's table of defaults, that is the /etc/opt/SUNWsamfs/samfs.cmd file.

This example assumes that the following Oracle Solaris Cluster objects exist:

  • A scalable resource group that is named scaldatadg-rg .

  • An instance of the SUNW.qfs resource type that is named qfs-db_qfs-Data-rs.

  • An instance of the SUNW.ScalDeviceGroup resource type that is named scaldatadg-rs.

# clresourcetype register SUNW.ScalMountPoint
# clresource create -t SUNW.ScalMountPoint \
-g scaldatadg-rg \
-p Resource_dependencies=qfs-db_qfs-Data-rs,scaldatadg-rs \
-p MountPointDir=/db_qfs/Data \
-p FileSystemType=s-qfs \
-p TargetFileSystem=Data \
scal-db_qfs-Data-rs

Attributes

See attributes(5) for descriptions of the following attributes:

ATTRIBUTE TYPE
ATTRIBUTE VALUE
Availability
ha-cluster/system/core

See Also

clresource(1CL), clresourcetype(1CL), clsetup(1CL), vfstab(4), attributes(5) , r_properties(5), SUNW.ScalDeviceGroup(5), SUNW.vucmm_framework(5)

Oracle Solaris Cluster Data Service for Oracle Real Application Clusters Guide , Oracle Solaris Cluster With Network-Attached Storage Device Manual