|Skip Navigation Links|
|Exit Print View|
|man pages section 4: File Formats Oracle Solaris 11 Information Library|
- set default system time zone and locale
This file sets the time zone environment variable TZ, and the locale-related environment variables LANG, LC_COLLATE, LC_CTYPE, LC_MESSAGES, LC_MONETARY, LC_NUMERIC, and LC_TIME.
/etc/TIMEZONE is a symbolic link to /etc/default/init.
The number of environment variables that can be set from /etc/default/init is limited to 20.
The format of the file is:
where VAR is a timezone environment variable and value is the value assigned to the variable. value can be enclosed in double quotes (”) or single quotes (’). The double or single quotes cannot be part of the value.
When changing the TZ setting on x86 systems, you must make a corresponding change to the /etc/rtc_config file to account for the new timezone setting. This can be accomplished by executing the following commands, followed by a reboot, to make the changes take effect:
# rtc -z zone-name # rtc -c
where zone-name is the same name as the TZ variable setting.
See rtc(1M) for information on the rtc command.