|Skip Navigation Links|
|Exit Print View|
|man pages section 9: DDI and DKI Kernel Functions Oracle Solaris 11 Express 11/10|
- set or get private state for an audio engine
#include <sys/audio/audio_driver.h> void *audio_engine_get_private(audio_engine_t *eng);
void audio_engine_set_private(audio_engine_t *eng, void *state)
pointer to an audio engine allocated with audio_engine_alloc(9F)
a private soft state structure for the device driver
Solaris DDI specific (Solaris DDI)
The audio_engine_set_private() function stores a pointer to the driver private state for the engine in the audio engine structure.
The pointer to the private state established by audio_engine_set_private() is passed as the first argument to the engine's entry points registered in the audio_engine_ops(9S) structure.
The audio_engine_get_private() function retrieves the previously stored private state pointer.
The audio_engine_get_private() function returns the device driver private state pointer.
These functions may be called from any context.
See attributes(5) for descriptions of the following attributes: