|Skip Navigation Links|
|Exit Print View|
|man pages section 9: DDI and DKI Kernel Functions Oracle Solaris 11 Express 11/10|
- return the data portion of a tuple
#include <sys/pccard.h> int32_t csx_GetTupleData(client_handle_t ch, tuple_t *tu);
Solaris DDI Specific (Solaris DDI)
Client handle returned from csx_RegisterClient(9F).
Pointer to a tuple_t structure.
The structure members of tuple_t are:
The fields are defined as follows:
uint32_t Socket; /* socket number */ uint32_t Attributes; /* tuple attributes*/ cisdata_t DesiredTuple; /* tuple to search for*/ cisdata_t TupleOffset; /* tuple data offset*/ cisdata_t TupleDataMax; /* max tuple data size*/ cisdata_t TupleDataLen; /* actual tuple data length*/ cisdata_t TupleData[CIS_MAX_TUPLE_DATA_LEN];/* tuple body data buffer*/ cisdata_t TupleCode; /* tuple type code*/ cisdata_t TupleLink; /* tuple link */
Not used in Solaris, but for portability with other Card Services implementations, it should be set to the logical socket number.
This field allows partial tuple information to be retrieved, starting anywhere within the tuple.
This field is the size of the tuple data buffer that Card Services uses to return raw tuple data from csx_GetTupleData. It can be larger than the number of bytes in the tuple data body. Card Services ignores any value placed here by the client.
This field is the actual size of the tuple data body. It represents the number of tuple data body bytes returned.
This field is an array of bytes containing the raw tuple data body contents.
Client handle is invalid.
No PC Card in socket.
No Card Information Structure (CIS) on PC Card.
Card Services was not able to read the tuple from the PC Card.
No PCMCIA hardware installed.
This function may be called from user or kernel context.
PC Card 95 Standard, PCMCIA/JEIDA