|Skip Navigation Links|
|Exit Print View|
|man pages section 9: DDI and DKI Kernel Functions Oracle Solaris 11 Express 11/10|
- determine the name given to a network interface
#include <sys/neti.h> int net_getifname(const net_data_t net, const phy_if_t ifp, char *buffer, size_t buflen);
Solaris DDI specific (Solaris DDI).
value returned from a successful call to net_protocol_lookup(9F).
pointer to the buffer in which to write the interface name.
size of the buffer in which to store the interface name.
The net_getifname() function copies the name of the network interface into the buffer provided. The name will always be null-terminated. If the buffer is too small to fit both the interface name and the null-terminated name, the name in the buffer is truncated to fit. See net_phygetnext(9F) for an example on how to use this function.
The net_getifname() function returns:
The network protocol does not support this function.
The net_getifname() function may be called from user, kernel, or interrupt context.
See attributes(5) for descriptions of the following attributes: