|Skip Navigation Links|
|Exit Print View|
|man pages section 9: DDI and DKI Kernel Functions Oracle Solaris 11 Express 11/10|
- map the memory area on a PC Card
#include <sys/pccard.h> int32_t csx_MapMemPage(window_handle_t wh, map_mem_page_t *mp);
Solaris DDI Specific (Solaris DDI)
Window handle returned from csx_RequestWindow(9F).
Pointer to a map_mem_page_t structure.
This function maps the memory area on a PC Card into a page of a window allocated with the csx_RequestWindow(9F) function.
The structure members of map_mem_page_t are:
uint32_t CardOffset; /* card offset */ uint32_t Page; /* page number */
The fields are defined as follows:
The absolute offset in bytes from the beginning of the PC Card to map into system memory.
Used internally by Card Services; clients must set this field to 0 before calling this function.
Client handle is invalid.
Offset is invalid.
Page is not zero.
No PC Card in socket.
No PCMCIA hardware installed.
This function may be called from user or kernel context.
PC Card 95 Standard, PCMCIA/JEIDA