|Skip Navigation Links|
|Exit Print View|
|man pages section 9: DDI and DKI Kernel Functions Oracle Solaris 11 Express 11/10|
- remove a character from a uio structure
#include <sys/uio.h> int uwritec(uio_t *uio_p);
Architecture independent level 1 (DDI/DKI)
Pointer to the uio(9S) structure
The uwritec() function returns a character from the uio structure pointed to by uio_p and updates the uio structure. See uiomove(9F).
The next character for processing is returned on success, and -1 is returned if uio is empty or if there is an error.
The uwritec() function can be called from user, interrupt, or kernel context.