|Skip Navigation Links|
|Exit Print View|
|man pages section 4: File Formats Oracle Solaris 10 8/11 Information Library|
- configuration file for libMPAPI
The /etc/mpapi.conf file is used to specify the vendor-provided plugin library that is installed on the system. This file is used by the libMPAPI(3LIB) common library to load the individual plugin library when its interface is called. If changes are made to the file while the library is in use, the library should be unloaded and reloaded. Addition and removal of the plugin library should be handled through MP_RegisterPlugin(3MPAPI) and MP_DeregisterPlugin(3MPAPI).
Each plugin library entry is a single line of the form:
"id" "library file name"
The identification of library. It is the resersed domain name of the vendor followed by “.” followed by the vendor specific name of the plugin thatuniquiely identifies the plugin library.
The shared object library file in the absolute path format.
Example 1 Example of an /etc/mpapi.conf file
# This file contains names and references to MP API plugin libraries # # Do NOT manually edit this file # # Format: # # <library ID> <library file name> # com.sun.mpapi32 /lib/libmpscsi_vhci.so com.sun.mpapi64 /lib/64/libmpscsi_vhci.so
See attributes(5) for descriptions of the following attributes: