|Skip Navigation Links
|Exit Print View
|man pages section 4: File Formats Oracle Solaris 10 8/11 Information Library
- template for Basic Registration information
The registration profile is a template for the information provided for Basic Registration. The information in this template is consumed by the sconadm(1M) utility. sconadm is the command-line alternative to the Basic Registration GUI.
An example of the registration profile template is provided in /usr/lib/breg/data/RegistrationProfile.properties. This file is owned by root, with read-only permissions. As root, you can copy the file to a location of your choosing and edit the file.
The registration profile template contains the following properties:
userName= password= hostName= subscriptionKey= portalEnabled= proxyHostName= proxyPort= proxyUserName= proxyPassword=
Values are not required for every property. The filling in or leaving blank a property depends on the task you intend to perform. Possible tasks are registering a new system, reregistering a system, and establishing a proxy. See sconadm(1M) for examples.
The properties defined for a registration template are as follows:
Corresponds to Sun Online Account user name.
Corresponds to Sun Online Account password.
Hostname of the machine to be registered (defaults to Unix host name, if not provided).
Enable access to all updates by providing your Sun Subscription Key for entitlement.
Note - The Sun Subscription Key is now known as the Sun Service Plan Number. However, the name of this field (subscriptionKey) remains unchanged.
If true, enable local client to be managed at the Sun-hosted Update Connection Service. If false, disable local client to be managed at the Sun-hosted Update Connection Service.
Your HTTP web proxy host name.
Your HTTP web proxy port number.
Your HTTP web proxy user name.
Your HTTP web proxy password.
Example 1 Sample Registration Profile
Below are the contents of a sample registration profile. Such a profile might be used to specify a proxy server with authentication.
userName= password= hostName= subscriptionKey= portalEnabled= proxyHostName=webcache.mycompany.com proxyPort=8080 proxyUserName=myCompanyProxyUserName proxyPassword=myCompanyProxyPassword
See attributes(5) for descriptions of the following attributes: