- SNMP Adapter Subagent for WBEM
/usr/sadm/lib/wbem/snmpXwbemd [-d] [-h] [-p port]
The snmpXwbemd daemon is a subagent in the Web-Based Enterprise Management (WBEM) services package.
This daemon maps the Simple Network Management Protocol (SNMP) requests forwarded by the Solstice Enterprise Agents (SEA) Master Agent snmpdx(1M) into one or more equivalent WBEM Common Information Model (CIM) properties and instances. Further, it remaps the response from the CIM Object Manager into a SNMP response, which it passes back to snmpdx(1M).
A mapping file contains the corresponding Object Identifier (OID), class name, property name, and Abstract Syntax Notation 1 (ASN.1) type for each object. You can also create your own mapping file.
The following options are supported:
Displays all debug information.
Displays help by printing the correct command line usage.
Specifies the port number to use.
The following operand is supported:
Specifies the port number you want to use.
例 1 An Example of a 050SUNWwbcou.map File
This mapping file that Sun Microsystems provides contains definitions of objects, in this format:
# #pragma ident "@(#)050SUNWwbcou.map 1.0 01/04/03 SMI" # # Copyright (c) 2001 by Sun Microsystems, Inc. # All rights reserved. # # *** Description of contents *** # # First non-commented non-blank line contains required Version label. # Remaining non-commented non-blank lines are considered map entries # used as described below: # # Column 1 - SNMP OID - Uniquely describes an SNMP variable # Column 2 - CIM Class Name - CIM class associated with this variable # Column 3 - CIM Property Name - CIM property that maps to SNMP OID variable # Column 4 - ASN.1 type - SNMP datatype that dictates how data is mapped # to/from SNMP requests. Supported types are: SnmpString, SnmpOid, # SnmpTimeticks, SnmpCounter, SnmpInt, SnmpGauge, SnmpIpAddress, # SnmpOpaque) # Column 5 and greater are ignored # Version 1.0 184.108.40.206.220.127.116.11.0 Solaris_ComputerSystem Description SnmpString 18.104.22.168.22.214.171.124.0 Solaris_OperatingSystem LastBootUpTime SnmpTimeticks 126.96.36.199.188.8.131.52.0 Solaris_ComputerSystem PrimaryOwnerContact SnmpString 184.108.40.206.220.127.116.11.0 Solaris_ComputerSystem Name SnmpString 18.104.22.168.22.214.171.124.5.0 Solaris_OperatingSystem NumberOfUsers SnmpGauge 126.96.36.199.188.8.131.52.6.0 Solaris_OperatingSystem NumberOfProcesses SnmpGauge 184.108.40.206.220.127.116.11.7.0 Solaris_OperatingSystem MaxNumberOfProcesses SnmpGauge 18.104.22.168.22.214.171.124.2.0 Solaris_OperatingSystem LocalDateTime SnmpString
Each definition of an object in this file contains an OID, its corresponding CIM class name, its corresponding CIM property name, and its corresponding ASN.1 type. Each of these elements is separated by a space character.
The SNMP Adapter Subagent for WBEM MIB–2 mapping file that Sun Microsystems provides contains SNMP Management Information Base (MIB) definitions for the CIM instrumentation that SNMP manages.
The following exit values are returned:
An error occurred.
See attributes(5) for descriptions of the following attributes.