- Make device_allocate entries
The mkdevalloc command writes to standard out a set of device_allocate(4) entries describing the system's frame buffer, audio, and removable media devices.
The mkdevalloc command is used by the device allocation service:
Entries are generated based on the device special files found in /dev. For the different categories of devices, the mkdevalloc command checks for the following files under /dev:
audio /dev/audio, /dev/audioctl, /dev/sound/... tape /dev/rst*, /dev/nrst*, /dev/rmt/... removable disk /dev/sr*, /dev/nsr*, /dev/dsk/c0t?d0s?, /dev/rdsk/c0t?d0s? frame buffer /dev/fb
All entries set the device-minimum and device-maximum fields to the hex representations of ADMIN_LOW and ADMIN_HIGH, respectively. The device-authorization field is set to solaris.device.allocate, except for the framebuffer entry, where it is set to *. The device-name, device-type and device-clean fields are set to the following values:
device-name device-type device-clean audio audio audio audio_clean_wrapper tape mag_tape_0,1,... st st_clean floppy floppy_0,1,... fd disk_clean removable disk cdrom_0,1,... sr disk_clean frame buffer framebuffer fb /bin/true
See attributes(5) for descriptions of the following attributes:
mkdevalloc might not be supported in a future release of the Solaris operating system.