man pages section 7: Device and Network Interfaces

Exit Print View

Updated: July 2014
 
 

jconvru (7M)

Name

jconvru - code conversion STREAMS module (Japanese EUC/UTF—8)

Synopsis

#include <sys/types.h>
#include <sys/stropt.h>
#include <sys/conf.h>
ioctl(fd, I_PUSH, "jconvru");

Description

jconvru is a STREAMS module that is available to be pushed onto a stream. Usually, this module has to be pushed onto a stream between terminal circuit module such as ldterm(7M) and STREAMS compatible module such as ttcompat(7M).

jconvru has to be pushed when you operate UTF-8 data. It converts up stream for Japanese EUC into UTF-8 and passes high module. It also converts down stream for UTF-8 into Japanese EUC and passes low module.

Ioctls

jconvru processes the following ioctls:

EUC_OXLON

Start performing code conversion between Japanese EUC and UTF-8 for I/O stream.

EUC_OXLOFF

Stop performing code conversion between Japanese EUC and UTF-8 for I/O stream.

Attributes

See attributes(5) for descriptions of the following attributes:

ATTRIBUTE TYPE
ATTRIBUTE VALUE
Availability
system/locale/extra

See also

setterm(1) , stty(1) , streamio(7I), jconv7(7M), jconv8(7M), jconvrs(7M), jconvs(7M), jconvu(7M), ldterm(7M), ptem(7M)

Notes

When you use jconvru with jconvu(7M), jconvs(7M), jconv7(7M), or jconv8(7M) at a time and `raw' is specified by stty(1) , code convert function automatically become off without specification by EUC_OXLON / EUC_OXLOFF .