man pages section 7: Device and Network Interfaces

Exit Print View

Updated: July 2014
 
 

jconvs (7M)

Name

jconvs - code conversion STREAMS module (PC kanji/Japanese EUC)

Synopsis

#include <sys/types.h>
#include <sys/stropt.h>
#include <sys/conf.h>
ioctl(fd, I_PUSH, "jconvs");

Description

jconvs is a STREAMS module that is available to be pushed onto a stream. Usually, this module has to be pushed onto a stream between a raw device such as ptem(7M) and terminal line discipline module such as ldterm(7M).

jconvs has to be pushed when you set PC kanji terminal. It converts up stream for PC kanji code into Japanese EUC and passes high module. It also converts down stream for Japanese EUC into PC kanji code and passes low module. jconvs controls terminal line discipline under PCK environment by using with jconvrs(7M).

Ioctls

jconvs processes the following ioctls:

EUC_OXLON

Start performing code conversion between PC kanji and Japanese EUC for I/O stream.

EUC_OXLOFF

Stop performing code conversion between PC kanji and Japanese EUC for I/O stream.

Attributes

See attributes(5) for descriptions of the following attributes:

ATTRIBUTE TYPE
ATTRIBUTE VALUE
Availability
system/locale/extra

See also

setterm(1) , stty(1) , PCK(5) , streamio(7I), jconv7(7M), jconv8(7M), jconvrs(7M), jconvru(7M), jconvu(7M), ldterm(7M), ptem(7M)

Notes

When you use jconvs with jconvrs(7M) or jconvru(7M) at a time and `raw' is specified by stty(1) , code convert function automatically become off without specification by EUC_OXLON / EUC_OXLOFF .

jconvs supports PC kanji/Japanese EUC code conversion under TOG Japanese Vendors Council (TOG/JVC) Recommended Code Set Conversion Specification between Japanese EUC and Shift–JIS.