プライマリ・コンテンツに移動
Oracle® Fusion Middleware Oracle WebCenter Sitesでの開発
12c (12.2.1)
E72540-01
目次へ移動
目次

前
前
次
次

28 Developer Toolsのインストールと構成

EclipseでWebCenter Sitesリソースの管理を開始するには、マシンでDeveloper Toolsを設定して、WebCenter SitesのインスタンスとEclipseを統合します。

Developer Toolsのインストール、構成および更新、およびEclipseでのWebCenter Sitesリソースの管理の詳細は、次の項を参照してください。

28.1 前提条件

Developer Toolsを設定する前に、次の点に注意してください。

  • Eclipse IDEとの統合に必要なDeveloper Toolsプラグインと、コマンドライン・ツールの実行可能JARファイルは、どちらもWebCenter Sitesインストールの${Oracle Home}/wcsites/clientsディレクトリにあります。

  • ローカルまたはリモートのどちらのWebCenter Sitesインスタンスに接続するかを決定します。

  • EclipseとWebCenter Sitesの統合が完了すると、WebCenter Sitesへのログインには、一般管理者の資格証明(fwadmin/xceladminなど)が必要になります。このユーザーは、RestAdminグループに属している必要があります。

  • コマンドライン・ツール機能を使用する手順:

    • Developer Toolsでは、接続先のWebCenter SitesインスタンスのCAS内部URLへのアクセス権が必要です。CAS内部URLは、Oracle WebCenter Sitesのインストール中に指定されます。Developer Toolsでアクセスできるように、内部URLへのアクセスを公開する必要があります。

      詳細は、『Oracle WebCenter Sitesのインストールと構成』を参照してください。

    • Developer Toolsについての高度な知識が必要です。コマンドライン・ツールの実行および使用方法の詳細は、「Developer Toolsコマンドライン・ツールの使用」を参照してください。

28.2 Developer Toolsの設定

Developer Toolsを設定するには、Developer Toolsプラグインをインストールして、WebCenter Sitesと統合し、リモート・ホストでコード補完を有効にします。Developer Toolsを使用した既存のリソースの使用方法およびリソースの管理方法の知識が必要です。

28.2.1 Developer Toolsプラグインのインストール方法

  1. 開発の要件に適したEclipseパッケージをダウンロードします。WebCenter Sitesの開発には、Eclipse IDE for Java EE Developersが推奨されています。Eclipseは、次のURLからダウンロードしてください。
  2. WebCenter Sitesのインストール・ディレクトリ(${Oracle Home}/wcsites/clients)のclientsフォルダを探します。このフォルダには、次のzipファイルが含まれます。
    • com.oracle.sites.developer-tools-xyz.zip: Developer Toolsプラグイン。

    • developer-tools-command-line.zip: コマンドライン・ツールのzipファイル(コマンドライン・ツールの実行可能JARファイルが含まれます)。

  3. Eclipseを起動します(eclipse.exeを実行します)。

    注意:

    Eclipseは、ローカル・ファイル・システム(またはアーカイブ)の場所とリモートの場所からプラグインをインストールします。プラグインの場所は、ソフトウェア・サイトと呼ばれています。Developer Toolsプラグインの場合、ソフトウェア・サイトは、ファイル・システム上のDeveloper Toolsプラグインへのパスになります。

  4. Eclipseのメニューから、「ヘルプ」を選択して、新規ソフトウェアのインストールを選択します。

    インストール・ウィザードが開始され、使用可能なソフトウェアが表示されます。

  5. 使用可能なソフトウェア・ページで、「追加」をクリックします(使用」フィールドの右側)。
  6. リポジトリの追加ダイアログで、次のフィールドに入力して、「OK」をクリックします。
    • 「Name」フィールドに、Developer Toolsプラグインの一意の名前を入力します。

    • 「場所」フィールドで、「アーカイブ」をクリックして、clientフォルダにあるDeveloper Toolsプラグインの場所(ソフトウェア・サイト)を指定します。

    インストール・ウィザードは、指定された場所(ソフトウェア・サイト)からDeveloper Toolsプラグインを選択して、使用可能なソフトウェアページにプラグインの名前をリストします。

  7. 使用可能なソフトウェアページで、「Oracle WebCenter Sites Developer Tools」を選択して、「次」をクリックします(図28-1を参照)。

    図28-1 インストール・ウィザード: Developer Toolsプラグインがリストされた使用可能なソフトウェア

    図28-1の説明が続きます
    「図28-1 インストール・ウィザード: Developer Toolsプラグインがリストされた使用可能なソフトウェア」の説明

    「インストールの詳細」ページが開きます。

  8. 「インストールの詳細」ページで、「終了」をクリックします(図28-2)。

    図28-2 インストール・ウィザード: 「インストールの詳細」ウィンドウ

    図28-2の説明が続きます
    「図28-2 インストール・ウィザード: 「インストールの詳細」ウィンドウ」の説明
  9. インストール・プロセス中に、「セキュリティ警告」ダイアログが開きます。「OK」をクリックして、イントールを続行してください。
  10. インストールが正常に完了すると、「ソフトウェアの更新」ダイアログが開きます。

    WebCenter Sitesが稼働していることを確認するには、${base_url}/HelloCSにアクセスします(${base_url}はWebCenter SitesインスタンスのベースURLです)。たとえば、ベースURLがhttp://example:8080/csの場合、http://example:8080/cs/HelloCSがWebCenter Sitesインスタンスの検証URLとなります。

  11. 「ソフトウェアの更新」ダイアログで「はい」をクリックして、Eclipseを再起動します。

    Eclipseを再起動すると、プラグイン・キャッシュがリフレッシュされ、EclipseでDeveloper Toolsプラグインが使用できるようになります。

28.2.2 Developer Toolsプラグインのインストールを確認する方法

  1. Eclipseの再起動後に、Developer Toolsプラグインが正常にインストールされていることを検証します。Eclipseのメニューから、「ヘルプ」を選択して、Eclipseのバージョン情報を選択します。

    Eclipseのバージョン情報ダイアログが開き、インストール済プラグインのリストにDeveloper Toolsアイコンが表示されます(図28-3)。

    図28-3 Eclipseのバージョン情報ダイアログ

    図28-3の説明が続きます
    「図28-3 Eclipseのバージョン情報ダイアログ」の説明
  2. Eclipse IDEの右上にあるパースペクティブを開くアイコンをクリックして、「Oracle WebCenter Sites」パースペクティブを開きます。パースペクティブを開くダイアログで、「Oracle WebCenter Sites」を選択して(図28-4)、「OK」をクリックします。

    図28-4 パースペクティブを開く: Oracle WebCenter Sites

    図28-4の説明が続きます
    「図28-4 「Open Perspective」: 「Oracle WebCenter Sites」」の説明

28.2.3 WebCenter SitesとEclipse IDEを統合する方法

初めてDeveloper Toolsを設定する場合は、構成フォームが自動的に表示されます。

WebCenter Sitesインスタンスに接続しており、別のインスタンスに接続するには、「WebCenter Sites」ツールバーに移動して、プリファレンスの構成ウィザードをクリックして構成フォームを開きます。

WebCenter SitesとEclipse IDEを統合するには、次のように、接続先のWebCenter Sitesインスタンスの情報を構成フォームに入力します。

  1. 「インスタンス」フィールドでは、ローカル・ホストとリモート・ホストのどちらに接続するかに応じて、次のいずれかの操作を実行します。

    注意:

    リモート接続では、同一のリモート・ホスト上で複数のプロジェクトの作成がサポートされます。ローカル接続では、同時にサポートされるプロジェクトは1つのみになります。

    • ローカル・ホストに接続する場合は、「参照」をクリックして、config (WebCenter Sitesインスタンスのwcs_properties.jsonファイルを含む)の場所を選択します。

    • リモート・ホスト(たとえば、http://example:8080/cs)に接続する場合は、ホストへのパスを[host]:[port]/[path]の書式で入力します。(http://またはhttps://を先頭に付ける必要があります。)

    「インスタンス」フィールドに値を入力すると、次の各フィールドには自動的に値が入力されます。これらのフィールドの値は、「インスタンス」フィールドでローカル・ホストとリモート・ホストのどちらを指定したかに応じて異なります。

    • Remote Connection: リモート・ホストに接続する場合、この値はtrueに設定されます。ローカル・ホストに接続する場合、この値はfalseに設定されます。

    • Host IP Address: 接続するホストのIPアドレスを指定します。

    • Port: 接続するホストのポート番号を指定します。

    • Web Context Path: ホストへのコンテキスト・パスを指定します。

    • Workspace: Developer Toolsワークスペース(Eclipseプロジェクト)の場所を指定します。

    • Sites Context Root: ローカル・ホストに接続する場合、このフィールドには、WebCenter Sites Webアプリケーションのパスが含まれます。リモート・ホストに接続する場合、このフィールドは空欄になります。

  2. 「プロジェクト名」フィールドに、作業するプロジェクトの名前を入力します。
  3. 「ユーザー名」フィールドに、一般管理者のユーザー名を入力します。このユーザーは、RestAdminグループのメンバーである必要があります。
  4. 「パスワード」フィールドに、ユーザー名のパスワードを入力します。
  5. オンラインにするチェック・ボックスを選択して、サーバーにアクセスし、EclipseでWebCenter Sitesリソースを使用します。
  6. 「接続のテスト」をクリックします。
    ダイアログが開き、接続が成功したことが表示されます。
  7. ダイアログ・ボックスで「OK」をクリックします。
  8. 確認フォームで「OK」をクリックします。

    「Oracle WebCenter Sites」パースペクティブが開きます。次の図に、「Oracle WebCenter Sites」パースペクティブの外観を示します(WebCenter Sitesが統合されたEclipseに初めてアクセスする場合)。

    注意:

    WebCenter Sitesリソースを使用する場合、「Oracle WebCenter Sites」パースペクティブを開く必要はありません。

    図28-6 「Oracle WebCenter Sites」パースペクティブ

    図28-6の説明が続きます
    「図28-6 「Oracle WebCenter Sites」パースペクティブ」の説明

Oracleパースペクティブが、前述の図に示すようにレンダリングされた場合は、Developer Toolsの設定に成功しています。WebCenter SitesがEclipseと統合されている場合、WebCenter Sitesリソースを使用するのに、「Oracle WebCenter Sites」パースペクティブを開く必要はありません。

注意:

EclipseビューとDeveloper Toolsビューを格納しているパネルは、相互に交換できます。別のパネルにビューを移動するには、ビューのタブをクリックして、そのタブをパネルにドラッグします。

28.2.4 リモート・ホストでコード補完を有効にする方法

  1. リモート・コンピュータからローカル・ファイル・システムにWEB-INFディレクトリをコピーします。EclipseとWebCenter Sitesを最初に統合したときに作成したワークスペース・フォルダにあるEclipseプロジェクト・フォルダにコピーすることをお薦めします。

  2. Eclipseの「プロジェクト」ビューで、WEB-INFフォルダを右クリックし、「プロパティ」を選択します。

    WEB-INFのプロパティ・ウィンドウが開きます。

    図28-7 WEB-INFのプロパティ・ウィンドウ

    図28-7の説明が続きます
    「図28-7 WEB-INFのプロパティ・ウィンドウ」の説明
  3. 「場所」フィールドで、「編集」をクリックします。

    リンクの場所の編集ウィンドウが開きます。

    図28-8 リンクの場所の編集ウィンドウ

    図28-8の説明が続きます
    「図28-8 リンクの場所の編集ウィンドウ」の説明
  4. 「場所」フィールドで、「フォルダ」をクリックして、手順1でコピーしたWEB-INFフォルダの場所に移動します。その後、「OK」をクリックします。

  5. WEB-INFのプロパティ・ウィンドウで、「OK」をクリックします。

    これにより、Eclipseでのタグ補完と、構文の適切な強調表示が可能になります。詳細は、「タグおよびJava APIの補完」を参照してください。

    注意:

    ローカル・インスタンスの場合、コード補完は自動的に有効化されます。

28.2.5 Developer Toolsを使用して既存のリソースを操作する方法

WebCenter Sitesシステムをアップグレードしていて、このリリースより前に作成したリソース(既存のリソース)に対してDeveloper Toolsを使用する場合は、「既存のリソースとDeveloper Toolsの併用について把握すべき内容」を参照してください。

28.2.6 WebCenter Sitesリソースを管理する方法

「Oracle WebCenter Sites」パースペクティブでWebCenter Sitesリソースの管理をすぐに開始するには、「EclipseでのWebCenter Sitesリソースの管理」に進んでください。

28.2.7 Eclipseで既存のプロジェクトを使用する方法

EclipseをWebCenter Sitesインスタンスと統合する場合、ワークスペースの名前と場所を指定します。後でこのワークスペースにアクセスする場合は、最初にWebCenter SitesをEclipse IDEに統合したときに「構成」フォームで指定した資格証明を使用してログインする必要があります。そうしないと、オフラインで作業することになり、EclipseでWebCenter Sitesリソースにアクセスできません。

Eclipse IDEで既存のプロジェクトを使用する手順:
  1. Eclipse IDEを開き、使用するWebCenter Sitesインスタンスに関連付けられているワークスペースを選択します。
    Eclipseが開きますが、オフライン・モードで操作している状態です。
  2. オンラインに切り替えてWebCenter Sitesインスタンスにアクセスするには、次のいずれかを実行します。
    • Eclipseで任意のWebCenter Sitesコンポーネントを選択します。

      例:

      1. 「新規テンプレートの作成」アイコンをクリックします。

        Errorダイアログが開き、現在のプロジェクトが現在オフラインである旨のメッセージが表示されます。

      2. 「はい」をクリックします。

        「資格証明」ダイアログが開きます。

      3. 「資格証明」ダイアログで、接続先のWebCenter Sitesインスタンスのユーザー名とパスワードを入力して、オンラインにするをクリックします。

    • 「構成」フォームを開き、次のように、接続先のWebCenter Sitesインスタンスの資格証明を入力します。

      1. 「WebCenter Sites」ツールバーで、プリファレンスの構成アイコンをクリックします。

        「構成」フォームが開きます。

      2. 「構成」フォームで、資格証明を「ユーザー名」フィールドと「パスワード」フィールドに入力します。

      3. オンラインにするチェック・ボックスを選択します。

        図28-9 構成フォーム

        この図は、「プリファレンス」ダイアログを示しています。
      4. 「OK」をクリックします。

    オンライン状態になり、EclipseでWebCenter Sitesリソースを作成および管理できます。

28.3 Developer Toolsの更新

WebCenter Sitesインストールをアップグレードしたら、次の手順を実行します。

28.3.1 Developer Toolsプラグインの場所を更新する方法

  1. 更新したDeveloper Toolsプラグイン(com.oracle.sites.developer-tools-xyz.zip)が{$Oracle Home}/wcsites/clientsディレクトリにあることを確認します。

    注意:

    Developer Toolsが最新バージョンであるかどうかを確認するには、zipファイルの名前に追加されているバージョン番号(xyz)を調べてください。

  2. Eclipseを起動します(eclipse.exeを実行します)。
  3. Eclipseのメニューから、「ヘルプ」を選択して、新規ソフトウェアのインストールを選択します。

    使用可能なソフトウェア・ダイアログが開きます。

  4. 使用可能なソフトウェア・ダイアログ・ボックスで、「追加」をクリックします。
  5. リポジトリの追加ダイアログで、次のフィールドに入力して、「OK」をクリックします。
    • 「名前」フィールドに、Developer Toolsプラグインの名前を入力します

    • 「場所」フィールドで、「アーカイブ」をクリックして、更新したプラグインの場所を指定して、「OK」をクリックします(図28-10)。

    図28-10 「リポジトリの追加」ダイアログ

    図28-10の説明が続きます
    「図28-10 「リポジトリの追加」ダイアログ」の説明
  6. 使用可能なソフトウェア・ダイアログ・ボックス(図28-11を参照)で、Developer Toolsプラグインの更新を選択して、「次」をクリックします。

    図28-11 使用可能なソフトウェア: 更新したプラグインの選択

    図28-11の説明が続きます
    「図28-11 使用可能なソフトウェア: 更新したプラグインの選択」の説明

    「インストールの詳細」ダイアログが開き、更新したプラグインが正常にインストールされたことが表示されます。

  7. 「インストールの詳細」ダイアログで、「終了」をクリックします。
  8. Eclipseを再起動して、変更を有効にします。

28.3.2 既存のプラグインの更新のチェック方法

  1. Eclipseのメニューから、「ヘルプ」を選択して、「更新の確認」を選択します。

    「使用可能な更新」ダイアログが開きます。

  2. 「Oracle WebCenter Sites Developer Tools」を選択して、「Next」をクリックします。

    更新の詳細ダイアログが開きます。

  3. 「終了」をクリックします。
  4. 更新プロセス中に、「セキュリティ警告」ダイアログが開きます。「OK」をクリックして、更新を続行してください。
  5. 更新が正常に完了すると、「ソフトウェアの更新」ダイアログが開きます。次の手順に進む前に、ローカルのWebCenter Sitesインスタンスを開始し、「ソフトウェアの更新」ダイアログで「はい」をクリックして、Eclipseを再起動します。

28.3.3 Developer Toolsプラグインが更新されていることを確認する方法

Eclipseが再起動されたら、Developer Toolsプラグインが最新バージョンに正常に更新されていることを検証します。

  1. Eclipseのメニューから、「ヘルプ」を選択して、Eclipseのバージョン情報を選択します。

    Eclipseのバージョン情報ダイアログが開き、インストール済プラグインのリストにDeveloper Toolsアイコンが表示されます(図28-12)。

    図28-12 Eclipseのバージョン情報ダイアログ

    図28-12の説明が続きます
    「図28-12 Eclipseのバージョン情報ダイアログ」の説明
  2. Eclipseのバージョン情報ダイアログで、Developer Toolsアイコンをクリックします。

    Eclipse機能についてウィンドウが開き、Developer Toolsプラグインのバージョン詳細が表示されます(図28-13)。

    図28-13 Eclipse機能についてウィンドウ

    図28-13の説明が続きます
    「図28-13 Eclipse機能についてウィンドウ」の説明

28.4 EclipseでのWebCenter Sitesリソースの管理

コード・ベースのWebCenter Sitesリソースの作成、編集、および他の方法による管理が可能です。

  • テンプレート・アセット

  • Controllerアセット

  • SiteEntryアセット

  • CSElementアセット

  • ElementCatalogエントリ

  • SiteCatalogエントリ

次の項では、Eclipseでリソースを管理するための手順の概要を示します。

28.4.1 リソースの作成方法

  1. ローカルのWebCenter Sitesを開始します。
  2. Eclipseを起動します。
  3. 「Oracle WebCenter Sites」パースペクティブを開きます。

    Eclipseのメニューで、「ウィンドウ」→「パースペクティブ」→パースペクティブを開く→「その他」→「Oracle WebCenter Sites」を選択します。

  4. 次のリソースのいずれかまたはすべてを作成します。
    • テンプレート・アセットを作成するには、「新規テンプレートの作成」アイコンをクリックして、フォームに入力します。

    • 新規Controllerアセットを作成するには、新規Controllerの作成アイコンをクリックして、フォームに入力します。

    • 新規CSElementアセットを作成するには、新規エレメントの作成アイコンをクリックして、フォームに入力します。

    • SiteEntryアセットを作成するには、新規サイト・エントリの作成アイコンをクリックして、フォームに入力します。

    • ElementCatalogエントリを作成するには、新規エレメント・カタログ・エントリの作成アイコンをクリックして、フォームに入力します。

    • SiteCatalogエントリを作成するには、新規SiteCatalogエントリの作成アイコンをクリックして、フォームに入力します。

    フィールド定義、およびテンプレート・アセット、CSElementアセット、SiteEntryアセット、SiteCatalogエントリおよびElementCatalogエントリの詳細は、「テンプレート・アセット、CSElementアセットおよびSiteEntryアセットの作成」を参照してください。フィールド定義およびControllerアセットの詳細は、「コントローラの作成」を参照してください。

  5. 「保存」をクリックすると、作成したリソースがWebCenter Sitesに自動的にインポートされます。
  6. 作成、編集、削除または他のサイトと共有するリソースを管理するには、サイト・ワークスペース・エレメント・ビューを使用します。リソースを右クリックし、オプションを選択します。使用可能なオプションの詳細は、「ワークスペース」を参照してください。

28.4.2 Developer Toolsビューをパネルに表示する方法

  1. ローカルのWebCenter Sitesを開始します。
  2. Eclipseを起動します。
  3. 「Oracle WebCenter Sites」パースペクティブを開きます。

    Eclipseのメニューで、「ウィンドウ」→パースペクティブを開く→「その他」→「Oracle WebCenter Sites」を選択します。

  4. 「Window」→「Show View」→「Other」の順に選択します。
  5. 「ビューの表示」ダイアログで、ビュー(Oracle WebCenter Sitesフォルダ内にあるビュー)を選択します。
    • サイトUIには、組込みのAdminインタフェースとOracle WebCenter Sites: Contributorインタフェースが表示されます。

    • サイト・ログ・ビューには、WebCenter Sitesのログ・ファイルが表示されます。

    • 開発者参照には、Oracle WebCenter Sitesタグ・リファレンスおよびOracle WebCenter Sites Java APIリファレンスが表示されます(タグ・リファレンスとJavadocを現在のWebCenter Sitesインスタンスに関連付けている場合のみ)。

    • 「Sites Workspace Elements」では、コード関連のリソースにアクセスできます。このビューでは、ツリーにリソースが表示され、各リソースはサイト・アフィリエーションに従ってグループ化されます。

    • 「ロギング構成」には、動的に更新されるログODL構成のビューが表示されます。このビューでは、各WebCenter Sitesログ出力のログ・レベルを設定できます。

    • プレビュー・ブラウザには、組込みのプレビュー・ブラウザが表示されます。

    • テンプレート・ビューには、Eclipsで作成されたすべてのテンプレート・アセットと、WebCenter SitesからEclipseにエクスポートしたテンプレート・アセットが表示されます。

Developer Toolsのビューの詳細は、「Developer Toolsのビューについて」を参照してください。

28.4.3 WebCenter SitesとDeveloper Toolsの間でデータをエクスポートおよびインポートする方法

  1. ローカルのWebCenter Sitesを開始します。
  2. Eclipseを起動します。
  3. 「Oracle WebCenter Sites」パースペクティブを開きます。

    Eclipseのメニューで、「ウィンドウ」→パースペクティブを開く→「その他」→「Oracle WebCenter Sites」を選択します。

  4. SynchUpアイコンを選択します。同期ツールを使用すると、WebCenter SitesからDeveloper Toolsワークスペースにデータをエクスポートしたり、Developer ToolsワークスペースからWebCenter Sitesにデータをインポートできます。

28.5 Developer Toolsのアンインストール

この項では、Developer Toolsをアンインストールする手順について説明します。

Developer Toolsをアンインストールする手順は次のとおりです。:

  1. 「Oracle WebCenter Sites」パースペクティブを閉じます(「Oracle WebCenter Sites」パースペクティブに関連付けられたすべてのビューも同時に閉じます)。
  2. Eclipseのメニューから、「ウィンドウ」を選択して、「プリファレンス」を選択します。

    「プリファレンス」ダイアログが開きます。

  3. 「インストール/更新」を選択して、アンインストールまたは更新リンクをクリックします(図28-14)。

    図28-14 プリファレンス: アンインストールまたは更新

    図28-14の説明が続きます
    「図28-14 プリファレンス: アンインストールまたは更新」の説明
  4. Eclipseインストールの詳細ページで、Developer Toolsプラグインを選択して、「アンインストール」をクリックします(図28-15)。

    図28-15 Eclipseインストールの詳細

    図28-15の説明が続きます
    「図28-15 Eclipseインストールの詳細」の説明
  5. アンインストールの詳細ページで、「終了」をクリックして、Developer Toolsプラグインのアンインストール・プロセスを続行します。
  6. 更新が正常に完了すると、「ソフトウェアの更新」ダイアログが開きます。「Yes」をクリックして、Eclipseを再起動します。

    Eclipseを再起動すると、プラグイン・キャッシュがリフレッシュされ、EclipseからDeveloper Toolsプラグインが完全に削除されます。