# Table of Contents

Overview .............................................................................................................................. 1
  Recommended Setup ........................................................................................................ 1
  IT Information ................................................................................................................ 1
  System Requirements .................................................................................................... 3
  Getting Started .............................................................................................................. 3
  Overview of OpenAir Exchange Manager Functions ...................................................... 4
Installation ........................................................................................................................... 6
  Installing OpenAir Exchange Manager ........................................................................ 6
  Uninstalling OpenAir Exchange Manager ................................................................ 8
Configuring OpenAir Exchange Manager ....................................................................... 10
Running the OpenAir Exchange Engine ......................................................................... 21
Using the Booking Status Feature ................................................................................... 22
Granting Rights to Mailboxes ........................................................................................... 24
  Instructions for Microsoft Exchange 2007 ................................................................. 24
  Instructions for Microsoft Exchange 2010 and Later Versions .................................... 24
References ........................................................................................................................ 25
  Frequently Asked Questions ......................................................................................... 25
Appendix A Outlook Calendar Event Examples ............................................................... 27
  OA Task Assignment in Outlook ................................................................................. 27
  OA Booking in Outlook ............................................................................................... 27
  OA Schedule Request in Outlook ................................................................................. 28
Overview

Introduction

This guide documents the OpenAir Exchange Manager. To simplify terminology in this guide, we may refer to the OpenAir Exchange Manager as Exchange Manager, Microsoft Outlook as Outlook and Microsoft Exchange as Exchange.

OpenAir Exchange Manager provides the ability to export project task assignments, resource bookings, and schedule request calendar commitments from OpenAir to users’ Outlook calendars.

In addition, this integration supports updates to bookings based on changes in corresponding Outlook events as well as conversion of Outlook events to OpenAir bookings. The bi-directional flow (Outlook to Exchange to OpenAir) allows a certain degree of control over bookings directly in the Outlook calendar. It also provides visibility into users’ Outlook calendars in OpenAir. Refer to the explanations that follow and the integration settings under Sync.

OpenAir Exchange Manager Applications

The OpenAir Exchange Manager includes two applications. Their use and required role privileges are as follows.

- **OpenAirExchange.exe** — Use OpenAir Exchange Setup to configure the integration. Enter OpenAir Settings, Exchange Settings, and map OpenAir user accounts to Microsoft Exchange ones. When necessary, manually edit and map Exchange Users.
- **OpenAirExchangeEngine.exe** — Use the OpenAir Exchange Engine to push OpenAir calendar objects to each configured Exchange account. The accounts and items designated for export are specified in OpenAir Exchange Setup.

**Note:** Only project task assignments with non-zero planned hours are exported.

Recommended Setup

We recommend that you install OpenAir Exchange Manager on a separate server/workstation on the same network as the company’s Microsoft Exchange Server. This ensures the integration has access to Microsoft Active Directory (AD) to query users, but does not store the integration on the same server.

- If Active Directory is unavailable, you need to manually set up mapping between OpenAir and Exchange Server users.
- If the OpenAir Exchange Manager is set up on a remote server outside the company network, the integration typically needs VPN access to the network to be able to interface with the Exchange Server.

IT Information

Protocols

The integration uses the following protocols:
OpenAir Exchange Manager uses the OpenAir XML API over SSL/HTTPS (port 443) to communicate with the OpenAir server. It pulls information from OpenAir, so no incoming ports need to be opened in the firewall. The integration makes only outgoing connections via SSL to access the OpenAir environment.

Active Directory Services Interface (ADSI) to obtain the user information for account mapping. Setup executes LDAP query against the local domain to determine the email addresses and home mailbox servers for the company’s Exchange users.

EWS or WebDAV to connect to Exchange Server and create appointments in users’ Outlook folders.

**Note:** Microsoft Exchange Server 2010 and later versions do not support WebDAV.

**Important:** If you setup Microsoft Exchange for EWS and use exchange integration you cannot change to WebDAV at a later date. However, you can change from WebDAV to EWS.

### Permissions

The integration requires the following permissions:

- OpenAir Administrator to be able to retrieve and update project task assignments, resource bookings, and schedule requests.
- Domain Administrator to retrieve the list of domain users and their mailbox details.
- Exchange Administrator to grant access to users’ mailboxes and modify Exchange settings if necessary.
- Domain User with read/write access to all user Exchange folders configured for the integration. This user account does not need to have Exchange or Enterprise administrator privileges and should be used for running the Exchange Engine.

### Settings

The integration requires the following settings are configured:

- When the ‘Use http’ option is checked, ensure that the Secure channel is not required on the Exchange virtual directory.
- Ensure that the standard authentication is configured for WebDAV. The integration will only work when ‘Basic’ Authentication is selected for the Exchange folder.

### Limitations

The integration has the following limitations:

- EWS limits the maximum calendar item duration to five years. If you create project task assignments, resource bookings or schedule request calendar commitments that exceed five years then during synchronization the integration will automatically limit the items created in the Outlook calendars to five years (i.e. to the maximum duration supported by EWS).

### Periodical Backups

We highly recommend that you backup the `oaexchdb.mdb` file periodically.
System Requirements

OpenAir Exchange Manager is supported on the following platforms:


OpenAir Exchange Manager supports communication with:

  For Microsoft Exchange Server 2007, FullAccessPermission for a mailbox is required.
  For Microsoft Exchange Server 2010 or later versions, ExchangeImpersonation is required.
  See Granting Rights to Mailboxes for more details.

Other requirements include:

- Microsoft .NET Framework Version 4.5 is required. The installer automatically downloads it if it is not currently installed
- RAM size of at least 1 GB is recommended.

Getting Started

The following steps outline what you need to do to begin using OpenAir Exchange Manager.

Step 1: Download OpenAir Exchange Manager

Professional Services provides you with a link for downloading OpenAir Exchange Manager. Refer to Installing OpenAir Exchange Manager.

Step 2: Ensure Appropriate OpenAir Internal Switches are Enabled

Access to OpenAir Exchange Manager must be enabled. To do so:

- Ensure that the internal switch labeled “Disable all access to OpenAir Exchange Manager” is NOT selected.
- Ensure that the internal switch labeled “Disable all access to OpenAir Outlook Connector” is selected. The Outlook Connector is a client-based integration application to pull OpenAir calendar events into a user’s Outlook. The Outlook Connector integration is not compatible with the OpenAir Exchange Manager integration.

Note: If OpenAir Outlook Connector was enabled prior to enabling the OpenAir Exchange Server, the internal switch to “Disable OpenAir Outlook Connector” must be manually selected.

Step 3: Configure OpenAir Exchange Manager Setup

OpenAir Exchange Manager Setup, which is used to configure the integration. Specifically:
■ It is used to map OpenAir user accounts to Exchange accounts.
■ Each Exchange account can be configured to pull one or all of the following: OpenAir project task assignments, bookings, and schedule requests.

**Note:** The OpenAir Exchange Manager Setup must be run by a user with a Windows administrator role.

### Step 4: Run OpenAir Exchange Manager Engine

OpenAir Exchange Manager Engine pushes OpenAir calendar information to each configured Exchange account. Specifically:

■ Each OpenAir calendar event gets exported to a user’s Outlook calendar.
■ Modifications or deletions of calendar events in OpenAir are replicated in Outlook.
■ Only new/updated/deleted items are transferred during each export.

**Note:** The OpenAir Exchange Manager Engine must be run by a user with a Windows administrator role.

### Overview of OpenAir Exchange Manager Functions

When you install OpenAir Exchange Manager, you can install an icon shortcut on the machine that OpenAir Exchange Manager resides. At your discretion, you can install the OpenAir Exchange icon in another location.

If you click on the icon, you launch the OpenAir Exchange Setup window.

![OpenAir Exchange Setup](image)

Tabs organize the following menu functions:
- **File** — Select Save, Update, or Exit. To save the results of an exchange, go to File > Save. To populate OpenAir and Microsoft Exchange accounts, go to File > Update. You can Exit OpenAir Exchange Manager by clicking on the Close button or go to File > Exit.

- **Options** — Select OpenAir Settings, Integration Settings, and Manually edit Exchange users. For more information of using each, see Configuring OpenAir Exchange Setup.

- **Help** — Select Help and then choose one of the following options:
  - **User Guide (pdf)** - displays the most recent OpenAir Exchange Admin Guide.
  - **Contents (Release notes)** — displays the most recent readme.txt file.
  - **OpenAir Web Site** — opens www.openair.com in your default Web browser window.
  - **Display Log** — Select one of two options: Configuration or Engine.
    - **Configuration** launches Notepad that loads OpenAirExchange.log. This log file lists all actions related to setup and configuration of the integration.
    - **Select Engine** to launch Notepad with OpenAirExchangeEngine.log. It lists all engine actions with their dates and times.
    - If you are having problems, we recommend that you send a copy of these files with each support request to OpenAir. See Troubleshooting.
  - **About OpenAir Exchange** — displays the About box with version information.
Installation

This chapter provides installation information on the following:

- Installing OpenAir Exchange Manager
- Uninstalling OpenAir Exchange Manager

Installing OpenAir Exchange Manager

**Important:** Before you begin, ensure you have disabled access to OpenAir Outlook Connector before installing and using OpenAir Exchange Manager. These two OpenAir programs cannot run simultaneously in your OpenAir account.

To download and install OpenAir Exchange Manager:

1. Click on the following URL:
   https://www.openair.com/download/OpenAirExchangeManager.exe
   The following confirmation window appears.

2. Click **Save File** and specify a location. Click **Save**.
3. Locate the `OpenAirExchangeManager.exe` file and double click it. Respond to any security questions.

   **Note:** `OpenAirExchangeManager.exe` must be run by a user with a Windows administrator role.

4. The **Welcome to the OpenAir Exchange Manager Setup Wizard** appears. Click **Next**.
5. The **OpenAir Exchange Manager License Agreement** appears. Read the agreement carefully and if you agree with the terms, click the **I accept the agreement** radio button and click **Next** to proceed with the installation.
6. The Select Destination Location window appears. You can click the Browse button to change the location where Exchange Manager will be installed. Click Next to install Exchange Manager to the indicated path.

7. The Ready to Install window appears. Click Install.

8. An information window with README.TXT appears. Click Next.
Installing OpenAir Exchange Manager

8

9. Click Finish. If you selected View readme.txt, the readme.txt file will open in a separate window.

Four new applications are added to the OpenAir Exchange Manager program folder: OpenAir Exchange Manager, Show console logs for Engine, Start Engine, and Stop Engine.

Uninstalling OpenAir Exchange Manager

When a new version of OpenAir Exchange Manager is available, you do not need to uninstall the version you are using. Simply download the new version and the installation process will update the application accordingly. However, if you will no longer be using OpenAir Exchange Manager and you need to uninstall it, follow these steps.

To uninstall OpenAir Exchange Manager:

1. Click the Start icon.
2. Select Settings > Control Panel and click Programs and Features. A list of the programs on your computer appears.
3. Select OpenAir Exchange Manager [version number].
4. Click Uninstall.
   A prompt appears to verify the action.
5. Click Yes.
   A message appears verifying the action.
6. Click OK.
7. To remove data mapping files manually, go to C:\Program Files\OpenAir\Exchange Server and delete them manually.
Configuring OpenAir Exchange Manager

Configuring OpenAir Exchange Setup

Use OpenAir Exchange Setup to configure the settings for your OpenAir Exchange Manager. Once it is configured, you can use the OpenAir Exchange Engine to run the integration and transfer OpenAir project assignments, bookings, and schedule requests through the Microsoft Exchange Server to users' Outlook accounts.

To configure OpenAir Exchange Setup:

1. Go to the application installation directory. (Typically it is C:\Program Files > OpenAir > ExchangeManager). Click OpenAirExchange.exe.

   The OpenAir Exchange Setup window appears.

OpenAir Settings

Before you can transfer data from OpenAir to the Microsoft Exchange Server, you need to log in to your OpenAir account using your OpenAir account credentials.

To enter your OpenAir account credentials:

1. Go to Options > OpenAir Settings.

   The following window appears. The credentials you enter here are used to retrieve data from your OpenAir account.
2. Type your Company ID, User ID, and Password. If you select the check box to Remember Password, you do not have to enter it again.

**Note:** The User ID must have Administrator role privileges in OpenAir.

3. The default Server is https://www.openair.com and should be used unless you are testing this integration using an https://sandbox.openair.com account.

4. Click OK. In most cases, leave Account ID blank.

**Note:** By clicking on the OK button, you understand and agree that the use of Oracle’s application is subject to the Oracle.com Terms of Use. Additional details regarding Oracle’s collection and use of your personal information, including information about access, retention, rectification, deletion, security, cross-border transfers and other topics, is available in the Oracle Privacy Policy.

### Integration Settings

Before you can transfer data from OpenAir to the Microsoft Exchange Server, you also need to review Integration Settings. They include:

- Active Directory
- Exchange Access
- Logging
- Sync

Each is explained in the following sections.

**To enter Integration Settings:**

1. Go to Options > Integration Settings. The following window appears.
2. Select the date to Export records modified after (last update). Click on the down arrow to display a calendar. Click Today to select today's date.

3. Click the tabs to display other integration settings such as Exchange Access, Logging, and Sync. The Active Directory appears by default when you select Integration Settings.

### Active Directory

Use the Active Directory tab to configure retrieval of users’ information from AD. In this tab, you can select whether to use LDAP or Azure AD (for integrating with Microsoft Office 365).

**To configure Exchange Manager to integrate using an LDAP Active Directory:**

1. In the Active Directory tab, select LDAP from the Choose the type of your AD drop-down list.
2. Enter the LDAP search filter. The LDAP search filter is for optional complex LDAP searches, and under normal circumstances, can be left with the default value. You can also query a global catalog.

   **Important:** If your organization is large and only a small group are OpenAir users, we recommend that you create a dedicated OpenAirUsers domain user group. The name of this group should be included in the LDAP search filter. The narrowed-down search restricts the global list of users to just OpenAir users. This simplifies the configuration and maintenance of the integration.

3. In the Active Director container box, select Use global catalog or Use domain.
   a. Select Use global catalog if exchange users exist on more than one Exchange Server in the forest. Provide the domain name for the forest root in the Global catalog or Domain field and Administrator credentials in the User name and Password fields to access the catalog of users.
   b. Select Use domain to retrieve exchange users from the AD domain. Provide the domain name in the Global catalog or Domain field and Administrator credentials in the User name and Password fields to access the catalog of users.
You can also click the **Autodetect domain** button to use the domain which the user's PC is connected to.

4. Click **OK**.

The Active Directory tab is also used to set up integrations to Microsoft 365 using Azure AD.

**To configure Exchange Manager to integrate with Microsoft Office 365:**

1. In the **Active Directory** tab, select **Azure AD** from the **Choose the type of your AD** drop-down list.
2. Type your Tenant, Client ID, UPN, and Password into the fields.
3. Click **Check connection** to test your connection to Microsoft 365. This will verify that you have the correct logon credentials and that you have set up the information correctly.
4. Click **OK**.
Configuring OpenAir Exchange Setup

Exchange Access

Use this tab to enter exchange access information.

1. Click the Exchange Access tab.
   The following window appears.

2. Choose your authentication type according to the Exchange Server Authentication configuration on the Exchange virtual directory for WebDAV and OWA for EWS. In most cases, you should be using Windows Integration Authentication.
3. Type your Domain (optional), Username (can be a UPN name), and Password. Provide a domain account that has read and write access permissions to the mailboxes of all users configured in the integration.

4. Select the Exchange Version you are using for the drop-down list of supported versions. The default is 2007 SP1 or earlier, which implies that by default WebDAV protocol is used to communicate with Exchange Server.

   **Important:** The following registry value can be set to force using EWS with Exchange 2007, which supports both WebDAV and EWS. We recommend this setting for new implementations in organizations that are likely to upgrade to Exchange 2010 in the future.

   If using a 32-bit operating system:
   ```plaintext
   [HKEY_LOCAL_MACHINE\SOFTWARE\OpenAir\ExchangeManager]
   ForceEws =dword:00000001
   ```

   If using a 64-bit operating system:
   ```plaintext
   [HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\OpenAir\ExchangeManager]
   ForceEws =dword:00000001
   ```

   **Important:** The integration does not support access to user mailboxes that can be accessed only via Exchange servers with different versions. However, access to all configured users' mailboxes is possible via Exchange servers of the same version.

5. Select the check box 'Use http' if the integration is local to the Exchange Server and the Exchange Server is not setup to accept https traffic.

6. Select the check box for 'Override SSL Exceptions' if the SSL certificate is not signed, or if the domain name used by the integration does not match the domain in the SSL certificate.

   **Important:** This is not recommended in remote setups.

7. Select the check box to 'Use full email address as mailbox name'.

8. Select the check box 'Use EWS Autodiscovery' to Autodiscover the correct EWS endpoint for Exchange users configured for integration.

   To use Autodiscover with Exchange 2007 you must also set the ForceEws registry value (see item 4).

   Selecting 'Use EWS Autodiscovery' disables the 'Use http' checkbox as this is obtained directly by Autodiscover.

   If Autodiscover fails for any user then the details are logged and the process continues with the remaining users.

   If the EWS URL is changed on the Exchange server side the Update function must be executed again to set the value in the Exchange Manager database (see Update AD and OpenAir User Lists).

   **Important:** The Autodiscover service uses an e-mail address to locate the configuration information that is needed to create a connection to an Exchange server. Only a credentialed user of the domain can use the Autodiscover service.

**Logging**

1. Use this tab to configure the transmission of the engine log to a designated email address. Click the Logging tab.
The following window appears.

2. Select the check box for 'Send results of each run' if you want a log of each sync to be mailed to the email address provided. A message is sent and if errors occur, the number of errors appears in the title of the message to alert the receiver.

3. Type the email address in To Email Address.

4. Type the Server Name.

5. Select whether to 'Use Authentication'. If checked, type the User name and Password.

6. Click OK.

Sync

Use this tab to configure synchronization of OpenAir bookings against Outlook calendar events. Synchronization currently does not support recurring calendar events. All-day events are brought in as 100% allocation bookings. Events with a start and end time create bookings with a specific number of hours.

1. Click the Sync tab.
   The following window appears.
2. Select the check box to Export Booking Notes as-is if you want to export booking notes with no other booking-related information. This allows the integration administrator to decide whether booking notes are exported purely with their content or as a formatted meta-field that includes hours, percentage, project, etc. in addition to the notes themselves. If bi-directional sync is enabled, this setting is also selected and uneditable to allow more straightforward field level merge logic.

3. Select **Enable bi-directional integration** if you want the integration to receive information from Outlook and import it to OpenAir.
   - If **Enable bi-directional integration** is selected, the Bi-Directional Settings group becomes available. This is a global application switch. After it is enabled, **Sync From Exchange** must be enabled for each user. To do so, go back to the Exchange Setup main screen and click in the **Sync From Exchange** column next to user. A red dot appears in the user row.
   - If this option is not selected, the flow of information is uni-directional from OpenAir to Outlook.

4. Specify the threshold date after which events are synced. When the integration is run, events created or modified after the specified date are exchanged. After each successful engine run, this date is updated accordingly.

5. Select which Conflict Resolution to use. Conflict Resolution determines which records to use when both records from OpenAir and MS Exchange Server are read. Choose **OpenAir wins** to prioritize OpenAir's records over the MS Exchange Server's, or **MS Exchange Server wins** to prioritize MS Exchange Server's records over OpenAir's.
6. Select Default Booking Properties. This includes the Booking Type and Customer-Project for bookings created from Outlook events.

   These settings are required for the bi-directional integration. User-level overrides can be configured for defining a default Booking Type and Customer-Project on an individual user level.

   To configure the override, go to Administration > Custom Fields and create the following custom fields associated with user:
   a. exchDefault_booking_type as Pick List with list source set as Booking Type.
   b. exchDefault_project as Pick List with list source set as Project.

7. Select the check box to allow Export private outlook events if desired. Generally, a private event is a calendar event that does not impact a project or billing, but indicate a user's time is allocated and therefore, not available for assignment. This is a global setting and it applies to all users mapped in this integration.

8. Select instructions for the integration to follow when a Deletion in Outlook occurs. Each is explained as follows:
   - is ignored by integration - If an event is deleted in Outlook, no action is taken. The integration does not delete OpenAir bookings.
   - deletes booking created from Outlook Event - If a booking is initially created from an Outlook event and the event is subsequently deleted, the integration deletes the matching booking in OpenAir. However, the integration does not delete bookings that are initially created in OpenAir.
   - deletes booking regardless of origin - If an Outlook event is deleted and a corresponding booking exists in OpenAir, the booking is deleted. It does not matter where a booking originates, it is automatically deleted.
   - changes booking type to - If a booking is deleted in Outlook, the integration automatically assigns a new booking type to the corresponding booking in OpenAir. For example, when a booking is deleted in Outlook, you may change its OpenAir booking type to Deleted. Therefore, when a user logs into OpenAir, the account reflects that a booking has a Deleted booking type, which indicates the booking was deleted in Outlook.

   Note: if the event is hard-deleted in Outlook, the integration is not able to detect that deletion. In addition, retention policy needs to be configured for deleted items so they are not removed from the store.

9. Click OK.

Update AD and OpenAir User Lists

After you have configured OpenAir Settings and Integration Settings, you should use the Update function to load OpenAir user accounts as well as Exchange accounts information into the integration. When OpenAir user email addresses are identical to those in Microsoft Exchange, they are
automatically mapped. You can then designate which items to export for each user. When email addresses are not identical, you should manually map Exchange users.

After you have completed account mapping, you can then designate which items to export for each user. You need to do this after you have enabled Sync From Exchange.

To update and populate OpenAir and Exchange accounts:

1. Go to Program Files > OpenAir > ExchangeManager and click OpenAirExchange.exe. The OpenAir Exchange Setup window appears.
2. Go to File > Update. OpenAir user and Microsoft Exchange information display.
3. Click on the colored dots to designate which items to export for each user. Refer to the following example.

**Important:** If users' time zone configuration changes in OpenAir, an administrator need to go to File > Update to refresh the information in the integration mapping.

Manually Edit Exchange Users

Items with identical email addresses map automatically, however, if they do not map, you can do this manually.

To manually add exchange users:

1. Go to Options > Manually edit Exchange users. The following window appears.

   When the window opens, the grid loads all Exchange users already present in the EIM (loaded either automatically or manually).

2. To add new users:
   1. Type in the values for Exchange email address and Exchange server in the empty grid fields (the last row in the grid).
   2. Press the “Enter” key on your keyboard or click the next empty grid field.

3. To remove users:
   1. Select user(s) in the Current Exchange Users list.
   2. Press the “Delete” key on your keyboard.

4. To set new exchange server names:
   1. Select user(s) in the Current Exchange Users list.
   2. Click the “Set Exchange server...” button.

The following window appears.
3. Enter the new Exchange server name.
4. Click the OK button.

5. To import users from a CSV file:
   1. Click the “Import from file...” button. The following window appears:

   ![Import from file window](image)

   2. Click the Browse button (...) to open a file browse dialogue and select the desired CSV file. CSV files used for this purpose must contain only 2 columns, have no header, include only plain data, and use a comma (,) as the separator, as below:

   ```
   admin@example.net, example
   admin@example.net, corp-exch-win2012-1
   mcollins@example.net, corp-exch-win2012-2
   ```

   3. Check the appropriate Import options (at least one must be enabled):
      - If “Add new users” is checked, the program will import any Exchange user from the CSV file whose email is not present in EIM.
      - If “Replace existing users” is checked, the program will replace existing Exchange users in the EIM with corresponding users found in the CSV file. No new users will be added unless “Add new users” is also checked.

   4. Click the “Run import” button to start processing the CSV file and import the Exchange users to the grid.

   **Note:** You can use the Shift and Ctrl keys when clicking to select multiple users. The “Set Exchange server” button applies to all the users selected in the Current Exchange Users list.
Running the OpenAir Exchange Engine

Once you have configured OpenAir Exchange Setup, you can use the OpenAir Exchange Engine to export bookings, schedule requests, and project assignments from OpenAir to users' Outlook accounts. The OpenAir Exchange Engine must be run by a user with a Windows administrator role. Read/write access to all user Exchange folders configured for the integration is required.

**Note:** Only project task assignments with non-zero planned hours are exported.

When the OpenAir Exchange Manager has been installed, four shortcuts are added to the location where you installed OpenAir Exchange Manager:

- OpenAir Exchange Manager — Opens the Exchange Manager interface
- Start Engine — Runs the Exchange Manager Engine in the background
- Stop Engine — Stops the Exchange Manager Engine
- Show console logs for Engine — Opens a log file which describes Exchange Engine's current progress if running, or a notification that it is not currently running.

Once opened, the OpenAir Exchange Engine runs continuously in the background, with the following process:

1. The Exchange Engine checks for new information in OpenAir. If new information is found, it downloads all new information from OpenAir.
2. The Exchange Engine sends records to Microsoft Exchange Server and waits for return information.
3. When return information is received from Microsoft Exchange Server, the Exchange Engine updates the OpenAir server.

**To run the OpenAir Exchange Engine:**

1. Go to the location where you installed the Exchange Manager shortcuts and click on or the Start Engine shortcut.
   
   A command line window opens and runs the OpenAir Exchange Manager as it has been configured. See Configuring OpenAir Exchange Setup.

**Note:** There is a known limitation due to the fact that some OpenAir calendar items are constrained only by dates with no start and end times of day. Such records export as an entire day. The subject and notes of each exported item specifies similar information to what appears in the OpenAir calendar.

**Warning:** Although it was recommended to use Windows Task Scheduler with versions of Exchange Manager prior to 4.0, as of version 4.0, OpenAir recommends not using Task Scheduler to run Exchange Manager.
Using the Booking Status Feature

You can export resource bookings from OpenAir to Outlook so that a **Status** or **Show as** state appears on the Outlook appointment form. If you do not use the booking status feature, the default status that appears is always Free.

To use the booking status feature, ensure you are using OpenAir Exchange Manager version 2.08 or a later version. Refer to the table that follows for an explanation of OpenAir Calendar Export Types and the status that appears in Outlook.

<table>
<thead>
<tr>
<th>When the OpenAir Calendar Export Type is...</th>
<th>Status appears in Outlook as...</th>
</tr>
</thead>
<tbody>
<tr>
<td>Set event time as busy</td>
<td>Busy*</td>
</tr>
<tr>
<td>Set event time as free</td>
<td>Free</td>
</tr>
<tr>
<td>Set event time as tentative</td>
<td>Tentative</td>
</tr>
<tr>
<td>Set event time as out of office</td>
<td>OOF</td>
</tr>
<tr>
<td>Do not export</td>
<td>Does not export OpenAir booking to Outlook</td>
</tr>
</tbody>
</table>

**Note:** *Busy status is set only for bookings that have a Start and End time defined.*

To use the booking status feature:

1. Go to Administration > Global Settings > Custom fields > Custom Fields and create a new custom field. Add a custom field to: Resources > Booking type and select a Dropdown type of field. Click Continue.

2. Type the Field name: `calendar_export_type`

3. Type a Description and Display name such as Calendar Export Type.

4. Click anywhere in the Values field. In the New Field Values window, click the `•` icon, and type “Do not export” in the field. Click OK.
Repeat this step for “Set event time as busy”, “Set event time as free”, “Set event time as tentative”, and “Set event time as out of office”.

**Note:** You must type each value exactly as shown in the image above.

5. We recommend that you do not select the **Required** check box unless you require that a Calendar Export Type be selected on each booking type.

6. Complete the custom field form and click **Save**.

7. Go to Administration > Application Settings > Resources Settings and select **Booking types**. Create new Booking types or select existing ones.

8. Scroll down to the custom field Calendar Export Type, which you just created. Select one of the following values: Do not export, Set event time as busy, Set event time as free, Set event time as tentative, and Set event time as out of office.

9. Go to Resources and when you create or edit a booking, choose a Booking type that is associated with the Calendar Export Type you desire.

10. Run the OpenAir Exchange Engine to export the booking to Outlook. See Using the Booking Status Feature.

    Outlook displays the OpenAir booking type status.
Granting Rights to Mailboxes

This chapter provides information on granting rights to Microsoft Exchange mailboxes:

- Instructions for Microsoft Exchange 2007
- Instructions for Microsoft Exchange 2010 and Later Versions

Instructions for Microsoft Exchange 2007

When using Microsoft Exchange 2007, Full Access permission for a mailbox is required for all Exchange users configured for integration to Sync OpenAir bookings against Outlook calendar events.

Please refer to the following Microsoft instructions:


Instructions for Microsoft Exchange 2010 and Later Versions

When using Microsoft Exchange 2010 or later versions of Microsoft Exchange, Exchange Impersonation is required for all Exchange users configured for integration to Sync OpenAir bookings against Outlook calendar events.

Please refer to the following Microsoft instructions:

Troubleshooting

The first step in troubleshooting is to ensure that you have installed the latest version of the OpenAir Exchange Manager so that you have the most recent enhancements, fixes, and features. Refer to Installing OpenAir Exchange Manager for more information and considerations for updating.

Create a Support Case

If you are experiencing difficulties with OpenAir Exchange Manager or would like to enable an internal switch, please create a support case and submit it through your OpenAir account.

To create a support case:
1. Log in to your OpenAir account and select Support from the User Center menu.
2. Click on the Go to SuiteAnswers button.
3. From the SuiteAnswers site home page, click Contact Support Online.
4. Enter your question keywords and click Search.

![Note:](image) If you do not have a question, i.e. you need a switch enabled, just click Search.

5. Very often the answer to your question will be displayed. If you still want to create a support case click Continue to Create Case.
6. Fill out the Create Case form and then click Submit. You will receive an email confirmation with Your OpenAir Customer Care #.

![Note:](image) An asterisk * displays after required fields.

Send the Log File

If you are still experiencing difficulties, please attach a zipped copy of the log file and to the support case, see Create a Support Case.

To obtain the log file:
1. Click Help and select Display Log.
   The log file displays.
2. Save the file, compress it to a zipped file, and attach it to the support case.

Our Support staff and engineers will work with you to find a solution to your problem.

Frequently Asked Questions

Questions may arise as you use OpenAir Exchange Manager.
1. The remote server returned an error: (403) Forbidden. What does it mean?
   Answer: There may be a mismatch between the configured version of Exchange Server in the Integration Settings and the actual version of the Exchange Server.

2. I got the following error message: Exchange Server doesn't support the requested version. What does it mean?
   Answer: This might also indicate there is a mismatch between the configured version of Exchange Server in the Integration Settings and the actual version of the Exchange Server.

3. An automated task has modified hundreds of old records in my OpenAir account, how can I exclude these from the Integration?
   Answer: In the Integration Settings dialog a user can specify an “Exclude records created” filter. This filter will only pass records that are considered new i.e. created within the number of days specified.

   Example: Consider the case when records created in 1999 have just been modified by an automated process. If these records are too old to be of interest you can set “Exclude records created”, e.g. to 30 days, to filter out these old records despite their modification date being today.
Appendix A Outlook Calendar Event Examples

Following are examples of Outlook appointments that were created from the OpenAir Exchange Manager integration. They include:

- OA Task Assignment in Outlook
- OA Booking in Outlook
- OA Schedule Request in Outlook

OA Task Assignment in Outlook

Below is an example of a project task assignment from OpenAir that has been created in Outlook via the OpenAir Exchange Manager integration. It includes task information as well as customer and project information.

![OA Task Assignment Example](image)

OA Booking in Outlook

Below is an example of a resource booking from OpenAir that has been created in Outlook via the OpenAir Exchange Manager integration. This example includes start time and end time information that was enabled in the associated OpenAir account for resource booking records.

![OA Booking Example](image)
OA Schedule Request in Outlook

- Below is an example of a schedule request from OpenAir that has been created in Outlook via the OpenAir Exchange Manager integration. It includes the amount of time requested and approval status as well as the start time and end time, duration, description, and notes.