Go to main content
Sun Server X3-2 (formerly Sun Fire X4170 M3) Product Notes Version 1.8

Exit Print View

Updated: July 2017
 
 

SAS expander firmware must be updated prior to updating HBA firmware

On systems with a Sun Storage 6 Gb SAS PCIe HBA card, it is critical that the SAS expander firmware is updated to version 0901 prior to updating the HBA firmware to version 11.00.00.00. If the HBA firmware is updated before the SAS expander, the system will not boot.


Note -  See also CR 7095163 in these product notes for important related information.

Affected hardware and software:

  • Sun Storage 6 Gb SAS PCIe HBA Internal (SG-SAS6-INT-Z and SGX-SAS6-INT-Z)

  • Releases 1.0, 1.1, 1.2, 1.3, 1.4.4, 1.5, 1.6, and 1.8

Workaround:

Use Oracle System Assistant to update the system firmware. Oracle System Assistant updates components automatically and will always update the SAS expander before updating the HBA. However, if you elect to update components one at a time (for example, by unchecking components in the Oracle System Assistant preview list for the Update Firmware task), it is critical to not update the HBA prior to the SAS expander.