|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 11.1 Information Library|
- Multicast DNS daemon
mdnsd is the daemon program for Multicast DNS and DNS Service Discovery.
The mdnsd daemon listens on UDP port 5353 for Multicast DNS Query packets. When it receives a query for which it knows an answer, mdnsd issues the appropriate Multicast DNS Reply packet.
The mdnsd daemon also performs Multicast DNS Queries on behalf of client processes, and maintains a cache of the replies.
The mdnsd daemon has no user-specifiable command-line argument, and users should not run mdnsd manually. The mdnsd daemon should be managed by the Solaris Management Facility (SMF) and should be administered by the svcadm(1M) command using the following fault management resource identifier (FMRI):
To examine mdnsd's internal state for debugging and diagnostic purposes, send it a SIGUSR1 signal, and it will then log a snapshot summary of its internal state using the syslog(3C) facility. mdnsd uses the syslog facility code daemon and info priority level.
The mdnsd daemon recognizes the following option:
Debug mode. The mdnsd daemon sends output to the standard error, and does not run in the background. This option is only intended for debugging the daemon.
Multicast DNS can be used to look up host names and host addresses by specifying mdns as a source for hosts and ipnodes in the name service switch configuration file nsswitch.conf(4). The configuration options for host name and host address queries using Multicast DNS are stored in the SMF repository. This configuration can be modified by the svccfg(1M) command using the following fault management resouce identfier (FMRI):
The configuration options for host name and host address queries using Multicast DNS are stored in a property group named “nss_mdns_config”. The properties that make up the configuration options are as follows:
A list of search domains for host name look up. By default, no search domains are included in the configuration. The search list is currently limited to six domains.
A list of valid domains checked before Multicast DNS is used to look up the host name or host address for a domain. Domains specified in the search list are always included in the valid list. The valid domain list is currently limited to ten domains.
Please note the above configuration options are Volatile and may change in a future release.
See attributes(5) for descriptions of the following attributes:
For information on Multicast DNS, see http://www.multicastdns.org/
For information on DNS Service Discovery, see http://www.dns-sd.org/.