|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 11.1 Information Library|
- make FIFO special file
/usr/bin/mkfifo [-m mode] path...
The mkfifo utility creates the FIFO special files named by its argument list. The arguments are taken sequentially, in the order specified; and each FIFO special file is either created completely or, in the case of an error or signal, not created at all.
If errors are encountered in creating one of the special files, mkfifo writes a diagnostic message to the standard error and continues with the remaining arguments, if any.
The mkfifo utility calls the library routine mkfifo(3C), with the path argument is passed as the path argument from the command line, and mode is set to the equivalent of a=rw, modified by the current value of the file mode creation mask umask(1).
The following option is supported:
Set the file permission bits of the newly-created FIFO to the specified mode value. The mode option-argument will be the same as the mode operand defined for the chmod(1) command. In <symbolicmode> strings, the op characters + and - will be interpreted relative to an assumed initial mode of a=rw.
The following operand is supported:
A path name of the FIFO special file to be created.
See largefile(5) for the description of the behavior of mkfifo when encountering files greater than or equal to 2 Gbyte (231 bytes).
See environ(5) for descriptions of the following environment variables that affect the execution of mkfifo: LANG, LC_ALL, LC_CTYPE, LC_MESSAGES, and NLSPATH.
The following exit values are returned:
All the specified FIFO special files were created successfully.
An error occurred.
See attributes(5) for descriptions of the following attributes: