|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 11.1 Information Library|
- report user-level lock statistics
plockstat [-vACHV] [-n count] [-s depth] [-e secs] [-x arg [=val]] command [arg]...
plockstat [-vACHV] [-n count] [-s depth] [-e secs] [-x arg [=val]] -p pid
The plockstat utility gathers and displays user-level locking statistics. By default, plockstat monitors all lock contention events, gathers frequency and timing data about those events, and displays the data in decreasing frequency order, so that the most common events appear first.
plockstat gathers data until the specified command completes or the process specified with the -p option completes.
plockstat relies on DTrace to instrument a running process or a command it invokes to trace events of interest. This imposes a small but measurable performance overhead on the processes being observed. Users must have the dtrace_proc privilege and have permission to observe a particular process with plockstat. Refer to the Solaris Dynamic Tracing Guide for more information about DTrace security features.
The following options are supported:
Watch all lock events. This option is equivalent to -CH.
Watch contention events.
Watch hold events.
Exit after the number of seconds specified have elapsed.
Display only the specified number of entries for each output category.
Record a stack trace rather than just the calling function.
Specify a process ID from which plockstat is to gather data.
Print out a message to indicate that tracing has started.
Enable or modify a DTrace runtime option or D compiler option. The list of options is found in the Solaris Dynamic Tracing Guide. Boolean options are enabled by specifying their name. Options with values are set by separating the option name and value with an equals sign (=).
Print the Dtrace commands used to gather the data. The output can then be used directly with the dtrace(1M) command.
The following operands are supported:
A string to be passed as an argument to command.
The name of a utility to be invoked.
A positive integer value.
A process identifier for a process to be monitored.
Duration specified as a positive integer number of seconds.
The following headers appear over columns of data in plockstat output.
Number of times an event occurred.
Average duration of an event, in nanoseconds.
Address of a lock, displayed symbolically if possible.
Address of a caller, displayed symbolically if possible.
The following exit values are returned:
An error occurred.
See attributes(5) for descriptions of the following attributes:
The command-line syntax is Committed. The human-readable output is Uncommitted.