|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 11.1 Information Library|
- check PolicyKit privileges
polkit-is-privileged [-hvV] -u user -p privilege [-r resource]
The polkit-is-privileged command queries system policy to determine whether a user is allowed for a given privilege and resource. The resource name can be omitted. On the Solaris operating system, RBAC authorizations names should be used as privilege names.
Currently, the only consumer of PolicyKit is hald(1M).
The following options are supported:
Display list of options and exit.
Name of privilege associated with user. Command tests for this privilege.
Name of resource associated with user and privilege. Command tests for this resource.
User name or user id that is tested for.
Displays version number.
See attributes(5) for descriptions of the following attributes: