|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 11.1 Information Library|
- mount and unmount a shared resource from an SMB file server
/usr/sbin/mount [-F smbfs] [generic-options] [-o name=value] [-O] resource
/usr/sbin/mount [-F smbfs] [generic-options] [-o name=value] [-O] mount-point
/usr/sbin/mount [-F smbfs] [generic-options] [-o name=value] [-O] resource mount-point
/usr/sbin/umount [-F smbfs] [generic-options] mount-point
The mount utility attaches a named resource, resource, to the file system hierarchy at the path name location, mount-point, which must already exist.
If mount-point has any contents prior to the mount operation, those contents remain hidden until the resource is unmounted. An authorized user with the SYS_MOUNT privilege can perform a mount operation. Also, a user can perform SMBFS mount operations on a directory the user owns.
If the resource is listed in the /etc/vfstab file, you can specify either resource or mount-point as the mount command will consult the /etc/vfstab file for more information. If the -F option is omitted, mount takes the file system type from the entry in the /etc/vfstab file.
If the resource is not listed in the /etc/vfstab file, the command line must specify both resource and mount-point.
The umount utility detaches a mounted file system from the file system hierarchy. An authorized user with the SYS_MOUNT privilege can perform a umount operation. Also, a user can perform SMBFS unmount operations on a directory the user owns.
The network/smb/client service must be enabled to successfully mount an SMB share. This service is enabled by default.
To enable the service, enter the following svcadm(1M) command:
# svcadm enable network/smb/client
The mount command supports the following operands:
The name of the resource to be mounted. In addition to its name, you can specify the following information about the resource:
server is the DNS or NetBIOS name of the remote computer.
share is the resource name on the remote server.
You can also specify the user account. See the “Options” section.
The mount command can read a password from standard input for the user account. If the password is not provided, mount first attempts to use the password stored by the smbadm add-key command (if any). If that password fails to authenticate, the mount_smbfs command prompts you for a password if standard input is a TTY.
The path to the location where the file system is to be mounted or unmounted. The mount command maintains a table of mounted file systems in the /etc/mnttab file. See the mnttab(4) man page.
See the mount(1M) man page for the list of supported generic-options.
Sets the file system-specific properties. You can specify more than one name-value pair as a list of comma-separated pairs. No spaces are permitted in the list. The properties are as follows:
Hold cached attributes for no more than n seconds after directory update. The default value is 60.
Hold cached attributes for at least n seconds after directory update. The default value is 30.
Hold cached attributes for no more than n seconds after file modification. The default value is 60.
Hold cached attributes for at least n seconds after file modification. The default value is 3.
Set minimum and maximum times for regular files and directories to n seconds. See “File Attributes,” below, for a description of the effect of setting this option to 0.
See “Specifying Values for Attribute Cache Duration Options,” below, for a description of how acdirmax, acdirmin, acregmax, acregmin, and actimeo are parsed on a mount command line.
Specifies the permissions to be assigned to directories. The value must be specified as an octal triplet, such as 755. The default value for the directory mode is taken from the fileperms setting, with execute permission added where fileperms has read permission.
Note that these permissions have no relation to the rights granted by the SMB server.
Specifies the name of the workgroup or the Windows domain in which the user name is defined. If the domain name is not specified, the default system's SMB domain is used.
Specifies the permissions to be assigned to files. The value must be specified as an octal triplet, such as 644. The default value is 700.
Note that these permissions have no relation to the rights granted by the SMB server.
Assigns the specified group ID to files. The default value is the group ID of the directory where the volume is mounted.
Enable (or disable) cancellation of smbfs(7FS) I/O operations when the user interrupts the calling thread (for example, by hitting Ctrl-C while an operation is underway). The default is intr (interruption enabled), so cancellation is normally allowed.
Suppress attribute caching. Local stat(2) calls always request attributes from the SMB server.
Suppresses the prompting for a password when mounting a share. This property enables you to permit anonymous access to a share. Anonymous access does not require a password.
The mount operation fails if a password is required, the noprompt property is set, and no password is stored by the smbadm add-key command.
Assigns the specified user ID files. The default value is the owner ID of the directory where the volume is mounted.
Specifies the remote user name. If user is omitted, the logged-in user ID is used.
Enable (or disable) Solaris Extended Attributes in this mount point. This option defaults to xattr (enabled Extended Attributes), but note: if the SMB server does not support SMB “named streams”, smbfs(7FS) forces this option to noxattr. When a mount has the noxattr option, attempts to use Solaris Extended attributes fail with EINVAL.
Overlays mount. Allow the file system to be mounted over an existing mount point, making the underlying file system inaccessible. If a mount is attempted on a pre-existing mount point without setting this flag, the mount fails, producing the error “device busy.”
To improve smbfs performance, file attributes are cached. File modification times get updated whenever any local modifications occur. However, file access times can be temporarily out-of-date until the cache gets refreshed.
The attribute cache retains file attributes on the client. Attributes for a file are assigned a time to be flushed. If the file is modified before the flush time, then the flush time is extended by the time since the last modification (under the assumption that files that changed recently are likely to change soon). There is a minimum and maximum flush time extension for regular files and for directories. Setting actimeo=n sets flush time to n seconds for both regular files and directories.
Setting actimeo=n disables attribute caching on the client. This means that every reference to attributes is satisfied directly from the server. While this guarantees that the client always has the latest file attributes from the server, it has an adverse effect on performance through additional latency, network load, and server load.
Setting the noac option also disables attribute caching. When smbfs is enhanced to support write caching, this option will have the further effect of disabling that write caching.
The attribute cache duration options are acdirmax, acdirmin, acregmax, acregmin, and actimeo, as described under OPTIONS, above. A value specified for actimeo sets the values of all attribute cache duration options except for any of these options specified following actimeo on a mount command line. For example, consider the following command:
# mount -F smbfs -o acdirmax=10,actimeo=1000 \ //server/share /mountpoint
Because actimeo is the last duration option in the command line, its value (1000) becomes the setting for all of the duration options, including acdirmax. Now consider:
# mount -F smbfs -o actimeo=1000,acdirmax=10 \ //server/share /mountpoint
Because the acdirmax option follows actimeo on the command line, it is assigned the value specified (10). The remaining duration options are set to the value of actimeo (1000).
Example 1 Mounting an SMBFS Share
The following example shows how to mount the /tmp share from the nano server in the SALES workgroup on the local /mnt mount point. You must supply the password for the root user to successfully perform the mount operation.
# mount -F smbfs -o user=root,domain=SALES //nano.sfbay/tmp /mnt Password:
Example 2 Verifying That an SMBFS File System Is Mounted
The following example shows how to mount the /tmp share from the nano server on the local /mnt mount point. You must supply the password for the root user to successfully perform the mount operation.
# mount -F smbfs -o user=root //nano.sfbay/tmp /mnt Password:
You can verify that the share is mounted in the following ways:
View the file system entry in the /etc/mnttab file.
# grep mnt /etc/mnttab //nano.sfbay/tmp /mnt smbfs dev=4900000 1177097833
View the output of the mount command.
# mount | grep mnt mnt on //nano.sfbay/tmp read/write/setuid/devices/dev=4900000 on Tue Apr 20 13:37:13 2010
View the output of the df /mnt command.
# df /mnt /mnt (//nano.sfbay/tmp): 3635872 blocks -1 files
Obtain information about the mounted share by viewing the output of the df -k /mnt command.
# df -k /mnt Filesystem kbytes used avail capacity Mounted on //nano.sfbay/tmp 1882384 64448 1817936 4% /mnt
Example 3 Unmounting an SMB Share
This example assumes that an SMB share has been mounted on the /mnt mount point. The following command line unmounts the share from the mount point.
# umount /mnt
Table of mounted file systems.
Default distributed file system type.
Table of automatically mounted resources.
Stores per-user settings for the Solaris SMB client.
See the attributes(5) man page for descriptions of the following attributes:
The Solaris SMB client always attempts to use gethostbyname() to resolve host names. If the host name cannot be resolved, the SMB client uses NetBIOS name resolution (NBNS). The Solaris SMB client permits the use of NBNS to enable Solaris SMB clients in Windows environments to work without additional configuration.
If the directory on which a file system is to be mounted is a symbolic link, the file system is mounted on the directory to which the symbolic link refers, rather than being mounted on top of the symbolic link itself.