|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 11.1 Information Library|
- query Internet name servers interactively
nslookup [-option] [name | -] [server]
The nslookup utility is a program to query Internet domain name servers. It has two modes: interactive and non-interactive. Interactive mode allows the user to query name servers for information about various hosts and domains or to print a list of hosts in a domain. Non-interactive mode is used to print just the name and requested information for a host or domain.
Interactive mode is entered in the following cases:
No arguments are given (the default name server is used).
The first argument is a hyphen (-) and the second argument is the host name or Internet address of a name server.
Non-interactive mode is used when the name or Internet address of the host to be looked up is given as the first argument. The optional second argument specifies the host name or address of a name server.
Options can also be specified on the command line if they precede the arguments and are prefixed with a hyphen. For example, to change the default query type to host information, and the initial timeout to 10 seconds, type:
nslookup -query=hinfo -timeout=10
Look up information for host using the current default server or using server, if specified. If host is an Internet address and the query type is A or PTR, the name of the host is returned. If host is a name and does not have a trailing period, the search list is used to qualify the name. To look up a host not in the current domain, append a period to the name.
Change the default server to domain; lserver uses the initial server to look up information about domain, while server uses the current default server. If an authoritative answer can't be found, the names of servers that might have the answer are returned.
Exits the program.
This command is used to change state information that affects the lookups. Valid keywords are:
Prints the current values of the frequently used options to set. Information about the current default server and host is also printed.
Change the query class to one of:
the Internet class
the Chaos class
the Hesiod class
The class specifies the protocol group of the information.
(Default = IN; abbreviation = cl)
Turn on or off the display of the full response packet and any intermediate response packets when searching.
(Default = nodebug; abbreviation = [no]deb)
Turn debugging mode on or off. This displays more about what nslookup is doing.
(Default = nod2)
Sets the search list to name.
If the lookup request contains at least one period but doesn't end with a trailing period, append the domain names in the domain search list to the request until an answer is received.
(Default = search)
Change the default TCP/UDP name server port to value.
(Default = 53; abbreviation = po)
Change the top of the information query.
(Default = A; abbreviations = q, ty)
Tell the name server to query other servers if it does not have the information. (Default = recurse; abbreviation = [no]rec)
Set the number of retries to number.
Change the initial timeout interval for waiting for a reply to number seconds.
Always use a virtual circuit when sending requests to the server.
(Default = novc)
Try the next nameserver if a nameserver responds with SERVFAIL or a referral (nofail) or terminate query (fail) on such a response.
(Default = nofail)
resolver configuration file
See attributes(5) for descriptions of the following attributes:
See the BIND 9 Administrator's Reference Manual. As of the date of publication of this man page, this document is available at https://www.isc.org/software/bind/documentation.
BIND 9 nslookup is deprecated and not as full featured as its BIND 8 version. For more features and functionality refer to dig(1M).
nslookup and dig(1M) now report “Not Implemented” as NOTIMP rather than NOTIMPL. This will have impact on scripts that are looking for NOTIMPL.