|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 11.1 Information Library|
- construct a udfs file system
mkfs -F udfs [generic_options] [-o specific_options] raw_device_file [size]
This is the universal disk format file system (udfs) -specific module of the mkfs command. mkfs constructs a udfs file system with a root directory.
See mkfs(1M) for the list of supported generic_options.
The following options are supported:
Specify a udfs-specific option. Specify udfs file system specific options in a comma-separated list with no intervening spaces. If invalid options are specified, a warning message is printed and the invalid options are ignored.
The following specific_options are available:
Print the file system parameters without actually creating the file system.
Specify the label to be written into the volume header structures. Specify string as the name of the label. If string is not specified, a default string is generated in the form of *NoLabel*.
The following operands are supported:
Specify the disk partition on which to write.
Specify the number of 512-byte blocks in the file system.
See attributes(5) for descriptions of the following attributes:
not currently a valid file system
The specified device does not contain a valid udfs file system.
Invalid size: larger than the partition size
Number of blocks given as parameter to create the file system is larger than the size of the device specified.
is mounted can't mkfs
Device is in use, cannot create file system when the device is in use.
Negative size parameter provided is invalid.
sector size must be between 512, 8192 bytes
Sector size given is not in the valid range.
Volume integrity sequence descriptors too long File set descriptor too long.
Not enough space to create volume integrity sequence or file set descriptor.
mkfs: argument out of range
One of the arguments is out of range.
mkfs: bad numeric arg
One of the arguments is potentially a bad numeric.
You can use lofiadm to create a file that appears to a mkfs command (for example, mkfs_pcfs or mkfs_ufs) as a raw device. You can then use a mkfs command to create a file system on that device. See lofiadm(1M) for examples of creating a UFS and a PC (FAT) file system on a device created by lofiadm.