man pages section 9: DDI and DKI Kernel Functions

Exit Print View

Updated: July 2014
 
 

csx_SetHandleOffset(9F)

Name

csx_SetHandleOffset - set current access handle offset

Synopsis

#include <sys/pccard.h>

int32_t csx_SetHandleOffset(acc_handle_t handle, uint32_t offset);

Interface Level

Solaris DDI Specific (Solaris DDI)

Parameters

handle

Access handle returned by csx_RequestIRQ(9F) or csx_RequestIO(9F).

offset

New access handle offset.

Description

This function sets the current offset for the access handle, handle, to offset.

Return Values

CS_SUCCESS

Successful operation.

Context

This function may be called from user or kernel context.

See also

csx_GetHandleOffset(9F), csx_RequestIO(9F), csx_RequestIRQ(9F)

PC Card 95 Standard, PCMCIA/JEIDA