man pages section 9: DDI and DKI Kernel Functions

Exit Print View

Updated: July 2014
 
 

ddi_getiminor(9F)

Name

ddi_getiminor - get kernel internal minor number from an external dev_t

Synopsis

#include <sys/types.h>
#include <sys/mkdev.h>
#include <sys/ddi.h>

minor_t ddi_getiminor(dev_t 
dev);

Interface Level

This interface is obsolete. getminor(9F) should be used instead.

Parameters

The following parameters are supported:

dev

Device number.

Description

ddi_getiminor() extracts the minor number from a device number. This call should be used only for device numbers that have been passed to the kernel from the user space through opaque interfaces such as the contents of ioctl(9E) and putmsg (2). The device numbers passed in using standard device entry points must continue to be interpreted using the getminor(9F) interface. This new interface is used to translate between user visible device numbers and in kernel device numbers. The two numbers may differ in a clustered system.

For certain bus types, you can call this DDI function from a high-interrupt context. These types include ISA and SBus buses. See sysbus (4) and isa (4) for details.

Context

ddi_getiminor() can be called from user context only.

Return Values

The minor number or EMINOR_UNKNOWN if the minor number of the device is invalid.

Attributes

See attributes(5) for a description of the following attributes:

ATTRIBUTE TYPE
ATTRIBUTE VALUE
Stability Level
Obsolete

See also

attributes(5), getmajor(9F), getminor(9F), makedevice(9F)

Writing Device Drivers for Oracle Solaris 11.2

Warnings

Drivers are required to replace calls to ddi_getminor.9f by getminor(9F)) in order to compile under Solaris 10 and later versions.