man pages section 9: DDI and DKI Kernel Functions

Exit Print View

Updated: July 2014
 
 

unbufcall(9F)

Name

unbufcall - cancel a pending bufcall request

Synopsis

#include <sys/stream.h>

void unbufcall(bufcall_id_t id);

Interface Level

Architecture independent level 1 (DDI/DKI).

Parameters

id

Identifier returned from bufcall(9F) or esbbcall(9F).

Description

The unbufcall function cancels a pending bufcall() or esbbcall() request. The argument id is a non-zero identifier for the request to be cancelled. id is returned from the bufcall () or esbbcall() function used to issue the request. unbufcall() will not return until the pending callback is cancelled or has run. Because of this, locks acquired by the callback routine should not be held across the call to unbufcall() or deadlock may result.

Return Values

None.

Context

The unbufcall function can be called from user, interrupt, or kernel context.

See also

bufcall(9F), esbbcall(9F)

Writing Device Drivers for Oracle Solaris 11.2

STREAMS Programming Guide