man pages section 9: DDI and DKI Kernel Functions

Exit Print View

Updated: July 2014
 
 

mioc2ack(9F)

Name

mioc2ack - Convert an M_IOCTL message to an M_IOCACK message

Synopsis

#include <sys/stream.h>
#include <sys/strsun.h>

void mioc2ack(mblk_t *mp, mblk_t *dp, size_t count, int rval);

Interface Level

Solaris DDI specific (Solaris DDI).

Parameters

mp

M_IOCTL message.

dp

Payload to associate with M_IOCACK message.

count

Value to set the ioc_count of the iocblk(9S) to.

rval

Value to set the ioc_rval of the iocblk(9S) to.

Description

The mioc2ack() function converts an M_IOCTL message into an M_IOCACK message using the supplied arguments.

To convert the message, mioc2ack() changes the message type to M_IOCACK, sets the ioc_count and ioc_rval members of the iocblk( 9S) associated with mp to the passed-in values, and clears the ioc_error field. Further, it frees any message blocks chained off of mp->b_cont and resets mp->b_cont to dp . Finally, if dp is not NULL, mioc2ack() resets dp->b_wptr to be dp->b_rptr + count (that is, it sets dp to be exactly count bytes in length).

Return Values

None.

Context

This function can be called from user, kernel or interrupt context.

See also

miocack(9F), miocnak(9F), iocblk(9S)

STREAMS Programming Guide