man pages section 9: DDI and DKI Kernel Functions

Exit Print View

Updated: July 2014
 
 

ddi_dma_devalign(9F)

Name

ddi_dma_devalign - find DMA mapping alignment and minimum transfer size

Synopsis

#include <sys/conf.h>
#include <sys/ddi.h>
#include <sys/sunddi.h>

int ddi_dma_devalign(ddi_dma_handle_t handle, uint_t *alignment, 
     uint_t *minxfr);

Interface Level

Solaris DDI specific (Solaris DDI). This interface is obsolete.

Parameters

handle

The DMAhandle filled in by a successful call to ddi_dma_setup(9F).

alignment

A pointer to an unsigned integer to be filled in with the minimum required alignment for DMA. The alignment is guaranteed to be a power of two.

minxfr

A pointer to an unsigned integer to be filled in with the minimum effective transfer size (see ddi_iomin(9F), ddi_dma_lim_sparc(9S) and ddi_dma_lim_x86(9S) ). This also is guaranteed to be a power of two.

Description

The ddi_dma_devalign() Function determines after a successful DMA mapping (see ddi_dma_setup(9F)) the minimum required data alignment and minimum DMA transfer size.

Return Values

The ddi_dma_devalign() function returns:

DDI_SUCCESS

The alignment and minxfr values have been filled.

DDI_FAILURE

The handle was illegal.

Context

The ddi_dma_devalign() function can be called from user, interrupt, or kernel context.

Attributes

See attributes(5) for descriptions of the following attributes:

ATTRIBUTE TYPE
ATTRIBUTE VALUE
Interface Stability
Obsolete

See also

ddi_dma_setup(9F), ddi_iomin(9F), ddi_dma_lim_sparc(9S), ddi_dma_lim_x86 (9S), ddi_dma_req(9S)

Writing Device Drivers for Oracle Solaris 11.2