man pages section 9: DDI and DKI Kernel Functions

Exit Print View

Updated: July 2014
 
 

ddi_binding_name(9F)

Name

ddi_binding_name, ddi_get_name - return driver binding name

Synopsis

#include <sys/ddi.h>
#include <sys/sunddi.h>

char *ddi_binding_name(dev_info_t *dip);
char *ddi_get_name(dev_info_t *dip);

Interface Level

Solaris DDI specific (Solaris DDI).

Parameters

dip

A pointer to the device's dev_info structure.

Description

ddi_binding_name() and ddi_get_name() return the driver binding name. This is the name used to select a driver for the device. This name is typically derived from the device name property or the device compatible property. The name returned may be a driver alias or the driver name.

Return Values

ddi_binding_name() and ddi_get_name() return the name used to bind a driver to a device.

Context

ddi_binding_name() and ddi_get_name() can be called from user, kernel, or interrupt context.

See also

ddi_node_name(9F)

Writing Device Drivers for Oracle Solaris 11.2

Warnings

The name returned by ddi_binding_name() and ddi_get_name() is read-only.