JavaScript is required to for searching.
Skip Navigation Links
Exit Print View
Oracle Switch ES1-24

Configuration Guide

search filter icon
search icon

Document Information

Using This Documention

Product Notes

Related Documentation

CLI Command Modes

Feedback

Support and Accessibility

Administering the Switch

Log In to the Oracle ILOM CLI

Create a SEFOS User

Change a SEFOS User Privilege Level

Configure Network Management From the Web Interface

Configure Network Management From the CLI

Log Out of the Oracle ILOM CLI

Update the Firmware

Administering SEFOS

SEFOS Setup Tasks

Understanding SEFOS Basics

Basic SEFOS Topology

Default Configurations

Connect to SEFOS

Disconnect From SEFOS

Configuring the SEFOS Environment

Enable or Disable the Timeout for Line Connections

Configure the Default IP Address

Configure the IP Address for an Interface

Configure the Name of the Configuration File

Configure the Default VLAN ID

Enable or Disable Trap Generation on an Interface

Configure Debug Logging

Configure ACL Filters

Configure QoS

Configure Port Mirroring

Configure Rate Limiting

Configuring Save Parameters

Managing Configuration Files

Save the Configuration to a File

Erase a Configuration File

Copy a Configuration File to a Remote Location

Copy a Configuration File From a Remote Location to Flash

Copy a Configuration File From One Remote Location or Flash to Another Remote Location or Flash

Managing Log Files

View a System Log

Copy a System Log to a Remote Location

View Debug Logs

Configuring the Switching Feature

Switching Feature Topology

Configure Initial Settings

Verify the Configuration

Configure VLAN Forwarding

Verify VLAN Membership

Configure RSTP

Configure LA

Save a Configuration

Configuring the Routing Feature

Routing Feature Topology

Configuring Static Routing

Configure Static Unicast Route Entries

Add Static Routes

Configuring Dynamic Routing

Configure RIP Dynamic Routing

Configure OSPF Dynamic Routing

Disabling Routing

Remove Static Routes

Disable RIP Dynamic Routing

Disable OSPF Dynamic Routing

Glossary

Index

Configure Static Unicast Route Entries

This task configures the static route entries in SEFOS and verifies that traffic is reachable across networks.


Note - Before performing this task, erase any previous configurations on the switches.


See Routing Feature Topology for the topology of this task.

  1. Configure the initial settings.

    See Configure Initial Settings.

  2. If GVRP and GMRP are enabled, disable them so that the VLAN creation will not be propagated.
    SEFOS-1# configure terminal
    SEFOS-1(config)# set gvrp disable
    SEFOS-1(config)# set gmrp disable
    SEFOS-1(config)# end
    SEFOS-1# show vlan device info
     
    Vlan device configurations
    --------------------------
    Vlan Status                       : Enabled
    Vlan Oper status                  : Enabled
    Gvrp status                       : Disabled
    Gmrp status                       : Disabled
    Gvrp Oper status                  : Disabled
    Gmrp Oper status                  : Disabled

    The set gvrp disable and set gmrp disable commands disable these protocols. The show vlan device info command shows the VLAN configuration information.

  3. Configure SEFOS-1.

    See Routing Feature Topology.

    1. Remove the IP address of VLAN 1.
      SEFOS-1# configure terminal
      SEFOS-1(config)# interface vlan 1
      SEFOS-1(config-if)# no ip address
      SEFOS-1(config-if)# exit
      SEFOS-1(config)# vlan 10
      SEFOS-1(config-vlan)# exit
      SEFOS-1(config)# interface range extreme-ethernet 0/1-2
      SEFOS-1(config-if-range)# switchport access vlan 10
      SEFOS-1(config-if-range)# no shutdown
      SEFOS-1(config-if-range)# exit
      SEFOS-1(config)# interface vlan 10
      SEFOS-1(config-if)# shut
      SEFOS-1(config-if)# ip address 10.0.0.201 255.255.255.0
      SEFOS-1(config-if)# no shutdown
      SEFOS-1(config-if)# end

      The default IP address of VLAN 1 is 10.0.0.1, and the IP address of VLAN 10 is 10.0.0.201. So you must remove the IP address of VLAN 1 before you can add the IP address for VLAN 10.

    2. Ping host A from SEFOS-1.
      SEFOS-1# ping 10.0.0.169
    3. Ping host A-2 from SEFOS-1.
      SEFOS-1# ping 10.0.0.152
    4. Ping SEFOS-1 and host A-2 from host A.
      # ping 10.0.201
      10.0.201 is alive
      # ping 10.0.0.152
      10.0.0.152 is alive
      #
  4. Configure the SEFOS-2 switch based on the topology.

    See Routing Feature Topology.

    SEFOS-2# configure terminal
    SEFOS-2(config)# interface vlan 1
    SEFOS-2(config-if)# no ip address
    SEFOS-2(config-if)# exit
    SEFOS-2(config)# vlan 40
    SEFOS-2(config-vlan)# exit
    SEFOS-2(config)# interface range extreme-ethernet 0/1-2
    SEFOS-2(config-if-range)# shutdown
    SEFOS-2(config-if-range)# switchport access vlan 40
    SEFOS-2(config-if-range)# no shutdown
    SEFOS-2(config-if-range)# exit
    SEFOS-2(config)# interface vlan 40
    SEFOS-2(config-if)# shutdown
    SEFOS-2(config-if)# ip address 40.0.0.200 255.255.255.0
    SEFOS-2(config-if)# no shutdown
    SEFOS-2(config-if)# end
    SEFOS-2#
  5. Ping host B and host B-2 from SEFOS-2.
    SEFOS-2# ping 40.0.0.110
    SEFOS-2# ping 40.0.0.118
  6. Create VLAN 20 between the two switches.

    Use ports 21 to 22 on both switches.

    1. Create VLAN 20 on SEFOS-1, ports 21 to 22.
      SEFOS-1# configure terminal
      SEFOS-1(config)# interface range extreme-ethernet 0/21-22
      SEFOS-1(config-if-range)# switchport access vlan 20
      SEFOS-1(config-if-range)# no shutdown
      SEFOS-1(config-if-range)# exit
      SEFOS-1(config)# interface vlan 20
      SEFOS-1(config-if)# shutdown
      SEFOS-1(config-if)# ip address 20.0.0.201 255.255.255.0
      SEFOS-1(config-if)# no shutdown
      SEFOS-1(config-if)# end
      SEFOS-1#
    2. Create VLAN 20 on SEFOS-2, ports 21 to 22.
      SEFOS-2# configure terminal
      SEFOS-2(config)# interface range extreme-ethernet 0/21-22
      SEFOS-2(config-if-range)# switchport access vlan 20
      SEFOS-2(config-if-range)# no shutdown
      SEFOS-2(config-if-range)# exit
      SEFOS-2(config)# interface vlan 20
      SEFOS-2(config-if)# shutdown
      SEFOS-2(config-if)# ip address 20.0.0.200 255.255.255.0
      SEFOS-2(config-if)# no shutdown
      SEFOS-2(config-if)# end
      SEFOS-2# ping 20.0.0.201

      You can now use this configuration as a starting point for different router configurations.

  7. Save the configuration.
    1. On on SEFOS-1, type.
      SEFOS-1# write startup-config
      Building configuration _
      [OK]
    2. On SEFOS-2, type.
      SEFOS-2# write startup-config
      Building configuration _
      [OK]

    Switches start with the saved configuration on reboot.

  8. Verify that the existing routes are available in SEFOS-1.
    1. On SEFOS-1, type.
      SEFOS-1# show ip route
      Codes: C - connected, S - static, R - rip, B - bgp, O - ospf
       
      C 10.0.0.0/24 is directly connected, vlan10
      C 20.0.0.0/24 is directly connected, vlan20
      SEFOS-1#
    2. On SEFOS-2, type.
      SEFOS-2# show ip route
      Codes: C - connected, S - static, R - rip, B - bgp, O - ospf
       
      C 20.0.0.0/24 is directly connected, vlan20
      C 40.0.0.0/24 is directly connected, vlan40
       
      SEFOS-2#

      If there is no known route from SEFOS-1 to host B, the ping from host A to host B fails.

  9. Configure the static route in the SEFOS-1, type.
    SEFOS-1# configure terminal
    SEFOS-1(config)# ip route 40.0.0.0 255.255.255.0 20.0.0.200
    SEFOS-1(config)# end
  10. Configure the static route in SEFOS-2.
    SEFOS-2# configure terminal
    SEFOS-2(config)# ip route 10.0.0.0 255.255.255.0 20.0.0.201
    SEFOS-2(config)# end
  11. Verify that the routes are known to SEFOS-1 and SEFOS-2.
    1. On SEFOS-1, type.
      SEFOS-1# show ip route
      Codes: C - connected, S - static, R - rip, B - bgp, O - ospf
      C 10.0.0.0/24 is directly connected, vlan10
      C 20.0.0.0/24 is directly connected, vlan20
      S 40.0.0.0/24 [-1] via 20.0.0.200
    2. On SEFOS-2, type.
      SEFOS-2# show ip route
      Codes: C - connected, S - static, R - rip, B - bgp, O - ospf
      S 10.0.0.0/24 [-1] via 20.0.0.201
      C 20.0.0.0/24 is directly connected, vlan20
      C 40.0.0.0/24 is directly connected, vlan40
Related Information