|Skip Navigation Links|
|Exit Print View|
|man pages section 4: File Formats Oracle Solaris 11 Express 11/10|
- configuration file for default router(s)
The /etc/defaultrouter file specifies a IPv4 host's default router(s).
The format of the file is as follows:
The /etc/defaultrouter file can contain the IP addresses or hostnames of one or more default routers, with each entry on its own line. If you use hostnames, each hostname must also be listed in the local /etc/hosts file, because no name services are running at the time that defaultrouter is read.
Lines beginning with the ``#'' character are treated as comments.
The default routes listed in this file replace those added by the kernel during diskless booting. An empty /etc/defaultrouter file will cause the default route added by the kernel to be deleted.
Use of a default route, whether received from a DHCP server or from /etc/defaultrouter, prevents a machine from acting as an IPv4 router. You can use routeadm(1M) to override this behavior.
Configuration file containing the hostnames or IP addresses of one or more default routers.