|Skip Navigation Links|
|Exit Print View|
|man pages section 4: File Formats Oracle Solaris 11 Express 11/10|
- prime/nonprime table for the accounting system
The /etc/acct/holidays file specifies prime time hours and holidays. Holidays and weekends are considered non-prime time hours.
/etc/acct/holidays is used by the accounting system.
All lines beginning with an * are comments.
The /etc/acct/holidays file consists of two sections. The first non-comment line defines the current year and the start time of prime and non-prime time hours, in the form of:
current_year prime_start non_prime_start
Specify prime_start and non_prime_start times in the range of 0000 to 2400.
The remaining non-comment lines define the holidays in the form of:
Of these two fields, only the month/day is actually used by the accounting system programs.
The /etc/acct/holidays file must be updated every year.
Example 1 An Example of the /etc/acct/holidays File
The following is an example of the /etc/acct/holidays file:
* Prime/Nonprime Table for the accounting system * * Curr Prime Non-Prime * Year Start Start * 1991 0830 1800 * * only the first column (month/day) is significant. * * month/day Company Holiday * 1/1 New Years Day 5/30 Memorial Day 7/4 Indep. Day 9/5 Labor Day 11/24 Thanksgiving Day 11/25 day after Thanksgiving 12/25 Christmas 12/26 day after Christmas