|Skip Navigation Links|
|Exit Print View|
|man pages section 4: File Formats Oracle Solaris 11 Express 11/10|
- configuration file for rpc.yppasswdd (NIS password daemon)
The yppasswdd file contains a parameter that modifies the behavior of the rpc.yppasswdd(1M) daemon.
The yppasswdd file contains a single parameter:
By default in the current release, this line in yppasswdd is commented out. If you uncomment the line, when a user attempts to change his default shell using `passwd -r nis -e` (see passwd(1)), the rpc.yppasswdd daemon checks whether the name of the user's current shell begins with an 'r'. rpc.yppasswdd considers any shell whose name begins with an 'r' (for example, rcsh) to be a restricted shell. If a user's shell does begin with 'r', his attempt to change from the default shell will fail.
If the line in the yppasswdd file is commented out (the default), the rpc.yppasswdd daemon does not perform the restricted shell check.
The yppasswdd file is editable only by root or a member of the sys group.
configuration file for rpc.yppasswdd daemon