|Skip Navigation Links|
|Exit Print View|
|man pages section 4: File Formats Oracle Solaris 11 Information Library|
- DAT static registry
The DAT static registry, /etc/dat/dat.conf is a system-wide data resource maintained by the system administrative command datadm(1M).
/etc/dat/dat.conf contains a list of interface adapters supported by uDAPL service providers. An interface adapter on Infiniband (IB) corresponds to an IB Partition instance, for example, p8001.ibp0. An IB partition object represents an IP interface plumbed by ifconfig(1M) on an IB partition/Host Channel Adapter port combination.
Each entry in the DAT static registry is a single line that contains eight fields. Fields are separated by a SPACE. Lines that begin with a pound sign (#) are considered comments. All characters that follow the # are ignored. Enclose Solaris specific strings (Solaris_specific_string) and service provider's instance data (service _provider_instance_data) in quotes.
The following shows the order of the fields in a dat.conf entry:
"interface_adapter_name" "API_version" "threadsafe | nonthreadsafe" \ "default | nondefault" "service_provider_library_pathname" \ "service_provider_version" "service _provider_instance_data"\ "Solaris_specific_string"
The fields are defined as follows:
Specifies the Interface Adapter (IA) name. In IB, this is the IB partition data-link name, for example, p8001.ibp0. This represents an IP interface plumbed on an IB partition/port combination of the HCA.
Specifies the API version of the service provide library: For example, "u"major.minor is u1.2.
Specifies a threadsafe or non-threadsafe library.
Specifies a default or non-default version of library. A service provider can offer several versions of the library. If so, one version is designated as default with the rest as nondefault.
Specifies the pathname of the library image.
Specifies the version of the service provider. By convention, specify the company stock symbol as the service provider, followed by major and minor version numbers, for example, SUNW1.0.
Specifies the service provider instance data.
Specifies a platform specific string, for example, the device name in the service_provider.conf file.
Example 1 Sample dat.conf File
The following dat.conf file shows a uDAPL 1.2 service provider for tavor, udapl_tavor.so.1 supporting two interfaces, p8001.ibp0 and p8001.ibp1:
# # dat.conf for uDAPL 1.2 # p8001.ibp0 u1.2 nonthreadsafe default udapl_tavor.so.1 SUNW.1.0 "" "driver_name=tavor" p8001.ibp1 u1.2 nonthreadsafe default udapl_tavor.so.1 SUNW.1.0 "" "driver_name=tavor"
See attributes(5) for descriptions of the following attributes:
datadm(1M), ifconfig(1M), libdat(3LIB), service_provider.conf(4), attributes(5)
An empty dat.conf is created during the package system/io/infiniband/udapl installation if no file is present beforehand. Entries in the file are added or removed by running datadm(1M).
The content of the platform specific string does not constitute an API. It is generated by datadm(1M) and might have a different content or interpretation in a future release.