|Skip Navigation Links|
|Exit Print View|
|man pages section 4: File Formats Oracle Solaris 11 Information Library|
- file containing commands for sharing resources across a network
This file is obsolete in the Oracle Solaris 11 release.
Adding share entries to the /etc/dfs/dfstab file is no longer required to permanently share files across a network. File systems are shared in the following ways:
The share command is used to create and publish a NFS or SMB share of a file system or directory. Using the share command to share a ZFS file system is considered a legacy operation.
The zfs set share command is used to establish NFS or SMB share properties for a ZFS dataset. Then, set the ZFS sharenfs or sharesmb to on to publish an NFS or SMB share.
An NFS or SMB share is published automatically when a system is rebooted by an SMF service. Because an SMF service manages NFS or SMB shares, editing the /etc/dfs/dfstab file is obsolete.
For more information, see the share(1M) manual page.
See attributes(5) for a description of the following attributes: