|Skip Navigation Links|
|Exit Print View|
|man pages section 4: File Formats Oracle Solaris 11 Information Library|
- configuration file for initgroups
The /etc/default/nss configuration file provides methods for initgroups(3C) lookup method. The file also provides a method to disable address sorting by name lookup functions. The file controls the behavior of the name service switch routines outside of the source database mappings provided by the /etc/nsswitch.conf file.
/etc/default/nss supports the following options:
Changes the behavior of the name service lookups to use the netid table in response to the initgroups() call. By default, initgroups() uses the group table. When NETID_AUTHORITATIVE is set to TRUE, initgroups() uses netid as the source for supplementary groups rather than the group table.
The name service administrator must ensure that the netid table contains valid supplementary group information for users. Not all name services can automatically keep the members listed in the group table in sync with the netid table.
If this option is set to FALSE, the sorting of addresses is disabled on addresses that are returned by name lookup functions such as initgroups(), gethostbyname(3NSL), netdir_getbyname(3NSL), getaddrinfo(3SOCKET), and getipnodebyname(3SOCKET). Setting this option to FALSE is useful when the order of addresses returned by the nameserver needs to be maintained. To use the DNS round robin feature, for example, address sorting by name lookup functions should be disabled.
By default, address sorting is enabled.
See attributes(5) for descriptions of the following attributes: