|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 11 Information Library|
- display file system shares or make local file system available for mounting by remote systems
share [-F protocol] -a
share [-F protocol] [-o options] [-d description] pathname [sharename]
share [-F protocol] [-A]
The share command defines and publishes a file system share, which means the file system is available for mounting through a sharing protocol.
If the -F protocol option is omitted, the first file sharing protocol listed in /etc/dfs/fstypes is used as the default.
Using the share command to define and publish an NFS or SMB share of a ZFS file system is considered a legacy operation. Consider using the zfs set share command to define NFS or SMB share properties and then set the ZFS sharenfs or sharesmb property to publish the share. For more information, see zfs(1M) and share_smb(1M).
In the third form of share command, as shown in the Synopsis above, share displays published shares or, with the -A option, displays all configured (defined) shares.
Specify the file sharing protocol.
Share pathname is published with read and write access to all clients. This is the default behavior.
Share pathname is published with read and write access only to the listed clients. No other systems can access the share pathname.
Share pathname is published with read-only access to all clients.
Share pathname is published with read-only access only to the listed clients. No other systems can access the share pathname.
Separate multiple options with commas. Separate multiple operands for an option with colons. See EXAMPLES.
Provide a comment that describes the file system share to be published.
Publish all defined shares.
Display all defined shares.
Example 1 Publishing an NFS Share With Read-Only Access
The following command defines and publishes an NFS share of /ufsfs with read-only access.
# share -F nfs -o ro /ufsfs
Example 2 Publishing an NFS Share with Multiple Share Options
The following command defines and publishes an NFS share of the /export/manuals file system with a netgroup called users_nfs who have read-only access and users from specified hosts who have read and write access.
# share -F nfs -o ro=users_nfs,rw=host1:host2:host3 /export/manuals
This file is obsolete. An SMF service publishes NFS or SMB shares at boot time.
List of file-sharing protocols. NFS is the default file sharing protocol.
See attributes(5) for descriptions of the following attributes:
If share commands are invoked multiple times on the same file system, the last share invocation supersedes the previous invocation. The options set by the last share command replace the old options. For example, if read-write permission was granted to usera on /somefs, then you want to grant read-write permission also to userb on /somefs, use the following syntax:
example% share -F nfs -o rw=usera:userb /somefs