|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 11 Information Library|
- print FRUID-specific information about the FRUs on a system or domain
/usr/sbin/prtfru [-d] | [-clx] [container]
The prtfru utility is used to obtain FRUID data from the system or domain. Its output is that of a tree structure echoing the path in the FRU (Field-Replaceable Unit) tree to each container. When a container is found, the data from that container is printed in a tree-like structure as well.
prtfru without any arguments will print the FRU hierarchy and all of the FRUID container data. prtfru prints to stdout which may be redirected to a file.
The following options are supported:
Prints only the containers and their data. This option does not print the FRU tree hierarchy.
Prints a DTD for the current registry to stdout.
Prints only the FRU tree hierarchy. This option does not print the container data.
Prints in XML format with a system identifier (SYSTEM) of prtfrureg.dtd.
Options -c and -l can be used together to obtain a list of the containers.
The folowing operand is supported:
The name of a particular container in the FRU hierarchy, that is, either the name or path/name of a container as displayed in the -l option.
The following exit values are returned:
All information was found and printed successfully.
An error has occurred.
See attributes(5) for descriptions of the following attributes: