|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 11 Information Library|
- turn ufs file system quotas on and off
quotaon [-v] filesystem...
quotaon -a [-v]
quotaoff [-v] filesystem...
quotaoff -a [-v]
quotaon turns on disk quotas for one or more ufs file systems.
Before a file system may have quotas enabled, a file named quotas, owned by root, must exist in the root directory of the file system. See edquota(1M) for details on how to modify the contents of this file.
quotaoff turns off disk quotas for one or more ufs file systems.
The file systems specified must already be mounted.
These commands update the mntopts field of the appropriate entries in /etc/mnttab to indicate when quotas are on or off for each file system. If quotas are on, the string quota will be added to mntopts; if quotas are off, the quota string is not present.
filesystem must be either the mount point of a file system, or the block device on which the file system resides.
This option is normally used at boot time to enable quotas. It applies only to those file systems in /etc/vfstab which have ``rq'' in the mntopts field, are currently mounted ``rw'', and have a quotas file in the root directory.
Display a message for each file system after quotas are turned on.
Force all file systems in /etc/mnttab to have their quotas disabled.
Display a message for each file system affected.
See largefile(5) for the description of the behavior of quotaon and quotaoff when encountering files greater than or equal to 2 Gbyte ( 231 bytes).
mounted file systems
list of default parameters for each file system
See attributes(5) for descriptions of the following attributes: