|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 11 Information Library|
- copy file to an NTFS volume
ntfscp [options] device source_file destination
The ntfscp utility copies files to an NTFS volume. destination (see Synopis) can be either a file or a directory. If destination is a directory specified by name, source_file is copied into this directory. If destination is a directory specified by inode number, an unnamed data attribute is created for this inode and source_file is copied into it. Consider possible negative consequence before specifying a directory by inode number: it is unusual to have an unnamed data stream in a directory.
All data on NTFS is stored in streams, which can have names. A file can have more than one data stream, but exactly one must have no name. The size of a file is the size of its unnamed data stream. Usually, when you do not specify a stream name, you are seeking access to the unnamed data stream. If you want access to a named data stream, you need to add :stream_name to the filename. For example, by opening some.mp3:artist you will open stream artist in some.mp3. In an operating system, such as Windows, that prevents you from accessing named data streams, you need to use some program like FAR or utilities from cygwin to access those streams.
Supported options are listed below. Most options have both single-letter and full-name forms. Multiple single-letter options that do not take an argument can be combined. For example, -fv is the equivalent of -f -v. A full-name option can be abbreviated to a unique prefix of its name.
Write to attribute designated by num.
Overrides some sensible defaults, such as not working with a mounted volume. Use this option with caution.
Show a list of options with a brief description of each one.
Treat destination (see Synopsis) as inode number.
Write to attribute with this name.
Use this option to make a test run before doing the actual copy operation. Volume will be opened read-only and no write will be done.
Suppress some debug, warning, and error messages.
Show the version number, copyright, and license information.
Display more debug, warning, and error messages.
Example 1 Copying from Home to Root Directory
The following command copies new_boot.ini from /home/user as boot.ini to the root of an /dev/dsk/c0d0p1 NTFS volume.
# ntfscp /dev/dsk/c0d0p1 /home/user/new_boot.ini boot.ini
Example 2 Copying a Stream
The following command copies myfile to C:\some\path\myfile:stream (assume that /dev/dsk/c0d0p1 drive designator is C).
# ntfscp -N stream /dev/dsk/c0d0p1 myfile /some/path
See attributes(5) for descriptions of the following attributes:
ntfscp was written by Yura Pakhuchiy, with contributions from Anton Altaparmakov and Hil Liao.