|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 11 Information Library|
- print system configuration
/usr/sbin/prtconf [-V] | [-F] | [-x] | [-bpv] | [-acdDlPuv] [dev_path]
The prtconf command prints the system configuration information. The output includes the total amount of memory, and the configuration of system peripherals formatted as a device tree.
If a device path is specified on the command line for those command options that can take a device path, prtconf will only display information for that device node.
The following options are supported:
Display all the ancestors device nodes, up to the root node of the device tree, for the device specified on the command line.
Display the firmware device tree root properties for the purpose of platform identification. These properties are “name”, “compatible”, “banner-name” and “model”.
Display the device subtree rooted at the device node specified on the command line, that is, display all the children of the device node specified on the command line.
Display vendor ID and device ID for PCI and PCI Express devices, in addition to the nodename.
For each system peripheral in the device tree, displays the name of the device driver used to manage the peripheral.
Show the /dev/chassis location associated with the device node. If -v is used, -l is implied.
Returns the device path name of the console frame buffer, if one exists. If there is no frame buffer, prtconf returns a non-zero exit code. This flag must be used by itself. It returns only the name of the console, frame buffer device or a non-zero exit code. For example, if the console frame buffer on a SUNW,Ultra-30 is ffb, the command returns: /SUNW,ffb@1e,0:ffb0. This option could be used to create a symlink for /dev/fb to the actual console device.
Displays information derived from the device tree provided by the firmware (PROM) on SPARC platforms or the booting system on x86 platforms.The device tree information displayed using this option is a snapshot of the initial configuration and may not accurately reflect reconfiguration events that occur later.
Includes information about pseudo devices. By default, information regarding pseudo devices is omitted.
Together with-v, displays information for each device listing properties from the vendor and admin lists, if any.
Specifies verbose mode.
Displays platform-dependent PROM (on SPARC platforms) or booting system (on x86 platforms) version information. This flag must be used by itself. The output is a string. The format of the string is arbitrary and platform-dependent.
Reports if the firmware on this system is 64-bit ready. Some existing platforms may need a firmware upgrade in order to run the 64-bit kernel. If the operation is not applicable to this platform or the firmware is already 64-bit ready, it exits silently with a return code of zero. If the operation is applicable to this platform and the firmware is not 64-bit ready, it displays a descriptive message on the standard output and exits with a non-zero return code. The hardware platform documentation contains more information about the platforms that may need a firmware upgrade in order to run the 64-bit kernel.
This flag overrides all other flags and must be used by itself.
The following operands are supported:
The path to a target device minor node, device nexus node, or device link for which device node configuration information is displayed
The following exit values are returned:
No error occurred.
With the -F option (SPARC only), a non-zero return value means that the output device is not a frame buffer. With the -x option, a non-zero return value means that the firmware is not 64–bit ready. In all other cases, a non-zero return value means that an error occurred.
See attributes(5) for descriptions of the following attributes:
Sun Hardware Platform Guide
The output of the prtconf command is highly dependent on the version of the PROM installed in the system. The output will be affected in potentially all circumstances.
The driver not attached message means that no driver is currently attached to that instance of the device. In general, drivers are loaded and installed (and attached to hardware instances) on demand, and when needed, and may be uninstalled and unloaded when the device is not in use.
On x86 platforms, the use of prtconf -vp provides a subset of information from prtconf -v. The value of integer properties from prtconf -vp might require byte swapping for correct interpretation.