|Skip Navigation Links
|Exit Print View
|man pages section 1M: System Administration Commands Oracle Solaris 11 Information Library
- STREAMS error logger cleanup program
strclean [-a age] [-d logdir]
strclean is used to clean up the STREAMS error logger directory on a regular basis (for example, by using cron. By default, all files with names matching error.* in /var/adm/streams that have not been modified in the last three days are removed.
The following options are supported:
The maximum age in days for a log file can be changed using the -a option.
A directory other than /var/adm/streams can be specified using the -d option.
Example 1 A sample of using the strclean command.
This example has the same result as running strclean with no arguments:
example% strclean -d /var/adm/streams -a 3
See attributes(5) for descriptions of the following attributes:
strclean is typically run from cron on a daily or weekly basis.