man pages section 4: File Formats

Exit Print View

Updated: July 2014
 
 

uumkey (4)

Name

uumkey - Kana-Kanji Conversion Operation Key Binding Definition File

Synopsis

/usr/lib/wnn/ja_JP/uumkey 

Description

uumkey is a file that sets Japanese language input keys. Each user can set a uumkey file to customize key operations. Lines beginning with colons (:) or semicolons (;) are comments.

OTHER ENTRIES

unset function_entry_name

Cancels previous settings for the specified entry.

Function Entry Setting Format

function_name

key_code [key_code ....]

Key codes can be given in octal, decimal, or hexadecimal notation and conform to notation used in the C programming language. The following notation can also be used for the control key:

Character
Notation
CTRL_A
^A

Up to 10 codes can be written for a single function. If the same function is set twice, the last setting takes priority. To bind more than one key to the same function, they must be bound at the same time. Only one function can be bound to a single key in the same mode.

FUNCTION ENTRIES

Not every function can necessarily operate in every mode. The following numbers are assigned to the described modes.

Operation Mode
Contents
0
Correction mode for conversion results after conversion
1
Text input mode before conversion
2
Phrase length adjustment mode after conversion
3
Buffer empty mode
4
Candidate selection mode while cursor is moving, i.e., the mode for selecting the next candidate, utility, part of speech for registration, or dictionary.
5
Predictive input mode

Entry names ending in _e have the same function as those without _e expect that they can also operate when the buffer is empty (mode 3). If the key setting to run rubout is not bound to a key, it will be the same as the erase key of the tty when uum is started.

The entry names and functions that can be set are described in the following table:

Table 221-1  Standard function entries
Entry name
Operation Mode
Function
henkan_on
01234
Turns the conversion mode ON and OFF. In conversion mode OFF, The Roman-alphabet KANA conversion automaton is also separated at the same time. The output code of the key code conversion by cvt_xim_tbl or automate can not be specified in the code set to the entry of henkan_on.
quote_keyin
01234
Quotes the next input character. This function is provided as a contingency measure to input code bound by henkan_on.
send_string
012
Attaches the code bound by this function to the text string in the conversion line and sends it to the application.
kakutei
0125
Sends the text string in the conversion line to the application.
one_char_kakutei
012
Confirms one character of the head
one_char_no_henkan
01
Changes one character of the head
forward_char
1
Moves the cursor one character to the right.
backward_char
1
Moves the cursor one character to the left. This function is called when conversion has been performed and then canceled and the cursor is at the left edge of the section of text for which conversion was canceled, the cursor will move one phrase to the left after performing continuous phrase conversion.
goto_top_of_line
1
Moves the cursor to the first character in the line.
goto_end_of_line
1
Moves the cursor to the last character in the line.
delete_char_at_cursor
15
Deletes the character at the cursor. In predictive input mode, the candidate at the cursor position is deleted from the candidate list of the predictive input.
kaijo
02
Returns the converted text string after the phrase containing the cursor to its preconverted state.
henkan
1
Performs continuous phrase conversion.
tan_henkan
1
Performs single phrase conversion.
nobi_henkan
2
When adjusting the phrase length, performs single phrase conversion for the section in reverse video as a short phrase and performs continuous phrase conversion there after.
jikouho
0
Displays the next candidate.
zenkouho
0
Displays the previous candidate.
select_jikouho
0
Displays the next candidate list.
kana_henkan
1
Performs Kanji-Kana conversion. However, it is effective only to use the backing form dictionary (the form that can be registered, Chinese character -> kana).
kill
1
Deletes the text string at and after the cursor and places it in the kill buffer.
yank
1
Inserts the contents of the kill buffer at the cursor position.
yank_e
13
Inserts the contents of the kill buffer at the cursor position.
bunsetu_nobasi
0
Increases the phrase length by one character.
bunsetu_chijime
0
Reduces the phrase length by one character.
sainyuuryoku
1
Replaces selection with the previously input Kana text string.
sainyuuryoku_e
13
Replaces selection with the previously input Kana text string.
kuten
1
Enters the Kuten_code input mode.
kuten_e
13
Enters the Kuten_code input mode.
jis
1
Displays JIS_code input screen.
jis_e
13
Displays JIS_code input screen.
sjis
1
Displays SJIS_code input screen.
sjis_e
13
Displays SJIS_code input screen.
kuten2
13
Displays Assistance_kuten_code input screen.
jis2
13
Displays supplementary JIS code input screen.
unicode_input
13
Displays UNICODE_code input screen.
next_ku_kuten
4
Displays the next Kuten of Kuten_list table.
previous_ku_kuten
4
Displays the previous Kuten of Kuten_list table.
next_page
4
Displays the next page of candidate_list (include Kuten_list).
previous_page
4
Displays the previous page of candidate_list (include Kuten_list).
redraw_line
0124
Redraws the conversion line.
redraw_line_e
01234
Redraws the conversion line.
previous_history
1
Replaces selection with the previous text string recorded in the history.
previous_history_e
13
Replaces selection with the previous text string recorded in the history.
next_history
1
Replaces selection with the next text string recorded in the history.
next_history_e
13
Replaces selection with the next text string recorded in the history.
all_history
1
Outputs all text strings recorded in the history as a next candidate list.
all_history_e
13
Outputs all text strings recorded in the history as a next candidate list.
quit
45
Closes windows of candidate list etc.
change_to_insert_mode
0
Enables editing of a converted text string. Converted Kanji will not be returned to Kana.
quote
1
Quotes the next input character if it is not a henkan_on character, i.e., the next character is not sent through roman character-Kana conversion, any key binding for it is ignored, and it is placed directly into the conversion line.
quote_e
13
Quotes the next input character if it is not a henkan_on character, i.e., the next character is not sent through roman character-Kana conversion, any key binding for it is ignored, and it is placed directly into the conversion line.
forward_select
4
In the mode to select candidates, the section in reverse video is moved.
backward_select
4
In the mode to select candidates, the section in reverse video is moved.
next_select
4
In the mode to select candidates, a move is made to the next screen.
previous_select
4
n the mode to select candidates, a move is made to the previous screen.
linestart_select
4
In the mode to select candidates, a move is made to the top of the screen.
lineend_select
4
In the mode to select candidates, a move is made to the end of the screen.
select_select
4
In the mode to select candidates, the mode is exited as soon as a candidate is selected.
send_ascii_char
01234
Prevents storage in the buffer of ASCII characters input when the buffer is empty.
not_send_ascii_char
01234
Causes ASCII characters to be stored in the buffer even when input when the buffer is empty.
toggle_send_ascii_char
01234
Toggles the status of operation status when ASCII characters are input when the buffer is empty.
quote_send_ascii_char
3
Places the next ASCII character into the buffer when the buffer is empty in the send_ascii_char mode, and then prevents storage in the buffer of ASCII characters input when the buffer is empty.
reconnect_jserver
01234
Reconnects jserver.
Table 221-2  Key bind subdivision
Entry Name
Operation Mode
Function
forward_bunsetsu
0
Moves forward one phrase. If not defined, the same key code as forward_char is used.
henkan_forward
2
Performs single phrase conversion for the section in reverse video, performs continuous phrase conversion thereafter, and then moves to the right one phrase. If not defined, the same key code as forward_char is used.
backward_bunsetsu
0
Moves to the left one phrase. If not defined, the same key code as backward_char is used.
henkan_backward
2
Performs single phrase conversion for the section in reverse video, performs continuous phrase conversion thereafter, and then moves to the left one phrase. If not defined, the same key code as backward_char is used.
top_bunsetsu
0
Moves to the beginning of the phrase. If not defined, the same key code as goto_top_of_line is used.
end_bunsetsu
0
Moves to the end of the phrase. If not defined, the same key code as goto_end_of_line is used.
jmptijime
2
Moves to the first character in the line. If not defined, the same key code as goto_top_of_line is used.
c_end_nobi
2
Moves to the last character in the line. If not defined, the same key code as goto_end_of_line is used.
forward
2
Increases the length of the phrase by one character. If not defined, the same key code as bunsetu_nobasi is used.
tijime
2
Decreases the length of the phrase by one character. If not defined, the same key code as bunsetu_chijime is used.
rubout
1
This is the rubout key. Deletes the character to the left of the cursor. rubout is also used in romkan, so the key code specification cannot be dynamically changed within a 1-byte range.
touroku
012
Displays word login screen.
touroku_e
0123
Displays word login screen.
bushu_e
0
Displays radical input screen.
tankan_henkan
01
Converts single kanji.
select_ikeiji_dai
01
Converts the strange character.
zip_henkan
012
Converts the ZIP code.
tel_henkan
012
Converts the the telephone number.
select_assoc_dai
0
Converts association. Displays the synonym.
hankaku
012
Converts input character into half-width.
eisuu
012
Converts input character into English alphanumerics.
hiragana
012
Converts input character into Hiragana.
katakana
012
Converts input character into Katakana.
eg_Aa_henkan_big_loop
012
The conversion of Hiragana → Katakana → half-width katakana → full-width Englishalphanumeric → half-width English alphanumeric is repeated.
eg_Aa_henkan_small_loop
012
The conversion of Hiragana → Katakana → half-width katakana is repeated.
reverse_conv
13
Displays reverse_convert screen.
codelist
13
Displays code_list screen.
unicode_codelist
13
Displays unicode_codelist screen.
greek
13
Displays greek list.
russian
13
Displays Russian list.
kigou
13
Displays sign list.
yosoku_modein
15
Selects predictive input candidate.

Examples

; Commands                  Codes
forward_char                ^F 0x90
jikouho                     ^N 0x92 ^W 0x9E
;yank                       ^Y
yank_e                      ^Y
select_select               32 ^J ^M 0x9E 0x9F

Warnings

Integers from 0 through 512 can be taken as code. Although not all of these numbers are generated from the keyboard, those that are generated from the keyboard are written unaltered as code. Numbers that cannot be generated from the keyboard (e.g., integers over 127) must go through key code conversion (cvt_xim_tbl) or must be generated through the Automaton.

Turning the conversion mode OFF has the same effect as temporarily disconnecting Wnn8LE. The roman character-Kana conversion Automaton is also simultaneously disconnected. Output codes for key code conversion cannot be designated for codes set as henkan_on entries.

Attributes

See attributes(5) for descriptions of the following attributes:

ATTRIBUTE TYPE
ATTRIBUTE VALUE
Availability
wnn

See also

uumrc(4), wnn_automaton(4)