Go to main content

man pages section 9: DDI and DKI Properties and Data Structures

Exit Print View

Updated: July 2017
 
 

hook_nic_event(9S)

Name

hook_nic_event - data structure describing events related to network interfaces

Synopsis

#include <sys/neti.h>
#include <sys/hook.h>
#include <sys/hook_event.h>

Interface Level

Solaris DDI specific (Solaris DDI).

Description

The hook_nic_event structure contains fields that relate to an event that has occurred and belongs to a network interface. This structure is passed through to callbacks for NE_PLUMB, NE_UNPLUMB, NE_UP, NE_DOWN and NE_ADDRESS_CHANGE events.

A callback may not alter any of the fields in this structure.

Structure Members


net_data_t           hne_family;      
phy_if_t             pkt_private;              
lif_if_t             hne_lif; 
nic_event_t          hne_event;
nic_event_data_t     hne_data;
size_t               hne_datalen;
 

The following fields are set for each event:

hne_family

A valid reference for the network protocol that owns this network interface and can be in calls to other netinfo(9F) functions.

hne_nic

The physical interface to which an event belongs.

hne_event

A value that indicates the respective event. The current list of available events is:

NE_PLUMB

an interface has just been created.

NE_UNPLUMB

An interface has just been destroyed and no more events should be received for it.

NE_UP

An interface has changed the state to “up” and may now generate packet events.

NE_DOWN

An interface has changed the state to “down” and will no longer generate packet events.

NE_ADDRESS_CHANGE

An address on an interface has changed. hne_lif refers to the logical interface for which the change is occurring, hne_data is a pointer to a sockaddr structure that is hne_datalen bytes long and contains the new network address.

NE_IFINDEX_CHANGE

An interface index has changed. hne_lif refers to the logical interface for which the change is occurring, hne_data is a new ifindex value.

Attributes

See attributes(5) for descriptions of the following attributes:

ATTRIBUTE TYPE
ATTRIBUTE VALUE
Interface Stability
Committed

See Also

attributes(5), netinfo(9F)