Go to main content

man pages section 9: DDI and DKI Properties and Data Structures

Exit Print View

Updated: July 2017
 
 

usb_string_descr(9S)

Name

usb_string_descr - USB string descriptor

Synopsis

#include <sys/usb/usba.h> 

Interface Level

Solaris DDI specific (Solaris DDI)

Description

The usb_string_descr_t string descriptor defines the attributes of a string, including size and Unicode language ID. Other USB descriptors may have string descriptor index fields which refer to specific string descriptors retrieved as part of a device's configuration.

Please refer to Section 9.6.7 of the USB 2.0 specification. The USB 2.0 specification is available at www.usb.org.

A string descriptor has the following fields:


uint8_t       bLength                Size of this descriptor,
                                     in bytes.


uint8_t       bDescriptorType        Set to USB_DESCR_TYPE_STRING.

uint16_t      bString[1];            Variable length Unicode encoded 
                                     string.

Attributes

See attributes(5) for descriptions of the following attributes:

ATTRIBUTE TYPE
ATTRIBUTE VALUE
Architecture
PCI-based systems
Interface Stability
Committed
Availability
system/io/usb

See Also

attributes(5), usb_get_alt_if(9F), usb_get_cfg(9F), usb_get_dev_data(9F), usb_get_string_descr(9F), usb_parse_data(9F), usb_ctrl_request(9S)